VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 algoritmo euromilhoes (RESOLVIDO)

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
falcaorsport
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 42
Localização : coimbra
Data de inscrição : 05/02/2009

MensagemAssunto: algoritmo euromilhoes (RESOLVIDO)   Qui Fev 05, 2009 8:47 pm

ajuda para por ordem numérica num geradore de xaves do euromilhoes.
so falta mesmo isso

var
a,b,c,d,t,f,g,l:inteiro
w:caractere

inicio
repita
repita
aleatorio 1,50
leia (a)
leia (b)
leia (c)
leia (d)
leia (t)
aleatorio off

ate(b<>a)e(c<>a)e(c<>b)e(d<>a)e(d<>b)e(d<>c)e(t<>a)e(t<>b)e(t<>c)e(t<>d)

repita
aleatorio 1,9
leia (f)
leia (g)
aleatorio off
ate (f<>g)
limpatela
// Agora vamos ordenar a chave
se a > b entao
l <- a
a <- b
b <- l
fimse
se a > c entao
l <- a
a <- c
c <- l
fimse
se b > c entao
l <- b
b <- c
c <- l
fimse
se a > d entao
l <- a
a <- d
d <- l
fimse
se b > d entao
l <- b
b <- d
d <- l
fimse
se c > d entao
l <- c
c <- d
d <- l
fimse
se a > t entao
l <- a
a <- t
t <- l
fimse
se b > t entao
l <- b
b <- t
t <- l
fimse
se c > t entao
l <- c
c <- t
t <- l
fimse
se d > t entao
l <- d
d <- t
t <- l
fimse
se f > g entao
l <- f
f <- g
g <- l
fimse
escreval ("a sua xave")
escreval (a,b,c,d,t)
escreval ("as suas estrelas")
escreval (f,g)
repita
escreval ("quer gerar nova xave? s/n")
leia (w)
ate (w="s")ou(w="n")
ate (w="n")

// Seção de Comandos
fimalgoritmo

RESOLVIDO
já feito

COM ESSE ALGORITMO JA PODEM GERAR AS VOSSAS XAVES DO EURO MILHOES E NO FINAL A XAVE SAI POR ORDEM NUMERICA

obrigado pela vossa atenção
Voltar ao Topo Ir em baixo
Ver perfil do usuário
madezion
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 38
Localização : coimbra
Data de inscrição : 09/02/2009

MensagemAssunto: Re: algoritmo euromilhoes (RESOLVIDO)   Seg Fev 09, 2009 9:38 am

Podes consultar o post colocado no dia 9.02.... lá ves como é resolvido esse problema de ordenação

Abraço
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
algoritmo euromilhoes (RESOLVIDO)
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [RESOLVIDO] Dinâmica de água
» [Resolvido] Como configuro o meu para aparecer as categorias em vez dos topicos?
» [Resolvido] Como por borda em uma iframe?
» [Resolvido] Ocultar fóruns do índice
» [Resolvido] Código do painel de usuário

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: