VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Euromilhoes.

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
madezion
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 38
Localização : coimbra
Data de inscrição : 09/02/2009

MensagemAssunto: Euromilhoes.   Seg Fev 09, 2009 9:36 am

Junto apresento o trabalho que executei para um modulo de pseudocodigo:

algoritmo "Euromilhões"
// Função : Gerar chave do euromilhões ordenada.
// Autor : Hugo Silva
// Data : 2009-02-07
// Seção de Declarações
var
//Numeração
a,b,d,f,g,k:inteiro
//Estrelas
i,h:inteiro
//Caracteres
s,c,n:caractere
inicio
repita
escreval ("*********************************************************************************")
escreval ("*****Vou gerar a chave de 5 números aleatórios quando pressionar a tecla c.******")
escreval ("*********************************************************************************")
repita
escreval
leia (c)
ate (c="c")
limpatela
//gerador numeros
aleatorio 1,50
leia (a)
leia (b)
se (b=a) entao
leia (b)
fimse
limpatela
leia (d)
se (d=a) ou (d=b) entao
leia (d)
fimse
limpatela
leia (f)
se (f=a) ou (f=b) ou (f=d) entao
leia (f)
fimse
limpatela
leia (g)
se (g=a) ou (g=b) ou (g=d) ou (g=f) entao
leia (g)
fimse
limpatela

//Ordenador Numeros
se a > b entao
k <- a
a <- b
b <- k
fimse
se a > d entao
k <- a
a <- d
d <- k
fimse
se a > f entao
k <- a
a <- f
f <- k
fimse
se a > g entao
k <- a
a <- g
g <- k
fimse
se b > d entao
k <- b
b <- d
d <- k
fimse
se b > f entao
k <- b
b <- f
f <- k
fimse
se d > f entao
k <- d
d <- f
f <- k
fimse
se b > g entao
k <- b
b <- g
g <- k
fimse
se d > g entao
k <- d
d <- g
g <- k
fimse
se f > g entao
k <- f
f <- g
g <- k
fimse
aleatorio off
//Gerador estrelas
aleatorio 1,9
leia (h)
limpatela
leia (i)
enquanto (i)=(h) faca
leia (i)
fimenquanto
limpatela
//Ordenamento estrelas
se i > h entao
k <- i
i <- h
h <- k
fimse
//Fim geradores e ordenadores
//Impressão Ecra
aleatorio off
escreval
escreval
escreval
escreval ("*********************************************************************************")
escreval
escreval ("____________________________________")
Escreval ("Esta é a sua chave:")
escreval (a,b,d,f,g)
escreval
escreval ("Estas são as suas estrelas:")
escreval (i,h)
escreval ("____________________________________")
escreval
escreval ("*********************************************************************************")
escreval
repita
escreval (" ____________________________________ ")
Escreval ("| Deseja gerar novos números? |")
escreval ("| |")
escreval ("| Pressione s ou n. |")
escreval ("|____________________________________|")
leia (s)
ate (s="n") ou (s="s")
ate (s="n")
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Euromilhoes.
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Pedido - script do euromilhoes

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: