VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Numeros impares e primos

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
colorado100%
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 22
Localização : Recife
Data de inscrição : 01/05/2009

MensagemAssunto: Numeros impares e primos   Sex Maio 01, 2009 9:58 pm

Ola... Estou precisando de um auxilio. Tenho que criar um algoritmo que lê valores inteiros, positivos e impares para um vetor de 20 posições. Escreve, a seguir,todos os valores lidos(em uma linha) e todos os valores lidos que forem primos(um em cada linha).

Nessa primeira parte, não estou conseguindo fazer com que os valores positivos sejam ignorados, eles aparecem com "0" qdo são listados.

var
i,a: inteiro
x: vetor [1..20] de inteiro
inicio
para i de 1 ate 20 passo 1 faca
escreval ("Digite um número")
leia (a)
se a%2<>0 entao
x[i] <- a
fimse
fimpara
limpatela
para i de 1 ate 20 passo 1 faca
escreva (x[i])
fimpara
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Numeros impares e primos
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» modificar pontuaçao rank numeros para rank nomes
» Como escureçer os Nomes e Numeros Do Fórum
» Personalizar numeros de páginas
» Para que serve estes numeros
» Colocar numeros nos slides do meu fórum

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: