VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 preciso de Ajuda

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
wesley
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 31
Localização : belém
Data de inscrição : 19/05/2009

MensagemAssunto: preciso de Ajuda   Ter Maio 19, 2009 3:47 pm

Implementar
um algoritmo para corrigir provas de múltipla escolha. Cada prova tem 10
questões e cada questão vale 1 ponto. O primeiro conjunto de dados a ser lido
será o gabarito para a correção da prova. Os outros dados serão os números dos
alunos e suas respectivas respostas, e o último número, do aluno fictício,
9999, indicando que não há mais alunos. O programa deve calcular e imprimir:



a) para cada aluno, seu número e sua nota;


b) a porcentagem de aprovação, sabendo-se
que a nota mínima de aprovação é 6;



c) a nota que teve a maior freqüência
absoluta, ou seja, a nota que apareceu mais vezes (supondo a inexistência de
empates).




esse algoritmo tá me deixando louco me ajudem

algoritmo "Correção de provas"

var
Gab:vetor[1..10] de caracter
resp:vetor[1..10] de caracter
soma,i:inteiro
inicio
escreval("gabarito da prova")
para i de 1 ate 10 faca
leia (Gab[i])
fimpara
escreval

escreval("resposta da prova")
para i de 1 ate 10 faca
se resp[i]=i entao
leia (resp[i])

soma<-soma+i
fimse
fimpara
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
preciso de Ajuda
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Comprei dominio preciso de ajuda
» Preciso de ajuda, esqueci a senha do meu fórum e o E-mail de registro
» Preciso de ajuda para por a lista de membros da forma decrescente por mensagem
» Olá! Preciso de Ajuda em Libras AV1 e AV2 2017, seguem as questões:
» [HELP] Preciso de ajuda, se possível.

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: