VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Video Locadora

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Olibetanio
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 40
Localização : Paulista-Pe
Data de inscrição : 31/05/2009

MensagemAssunto: Video Locadora   Dom Maio 31, 2009 9:48 am

Ola a todos vi o algoritimo de uma locadora respondido ai, mais o que eu quero tem opções diferentes desse ai por isso vim pedir ajuda no algoritimo que fiz vou postar ele aqui junto com os detalhes do que foi pedido para o trabalho.

Ps: se puderem me ajudar urgente o trabalho é para ser entregue na segunda feira.
meu msn é olibetanio@hotmail.com

O programa deve implementar vetores para armazenar:

1. Os códigos dos filmes
2. Os títulos dos filmes
3. Quantidades de cópias de cada filme
4. Quantidade de cópias disponíveis
5. Quantidade de cópias locadas
6. Data de locação
7. Data de devolução

O programa deve ter as seguintes funcionalidades:

· Consulta de filme por nome e código.
· Consulta de quantidade de cópias disponíveis por filme
· Efetuar locação de filmes
· Efetuar devolução de filmes.
· Imprimir a lista de filmes em ordem alfabética
· Imprimir a quantidade total

algoritmo "semnome"
// Função :
// Autor :
// Data : 25/5/2009
// Seção de Declarações
var
menu,controle,x,x2,y,dev,c,min,d,d2,t,aux,qgcfil: inteiro
tit:vetor[1..10]de caractere
cod:vetor[1..10] de inteiro
dsai:vetor[1..10] de caractere
ddev:vetor[1..10] de caractere
qcfil:vetor[1..10] de inteiro
aux1,s,n ,esc:caractere
inicio
// Seção de Comandos



escreval("--------locadora Reis----------")
escreval("--------Menu-------- ")
escreval("1 - cadastro")
escreval("2 - locação")
escreval("3 - devolução")
escreval("4 -Listar filmes")
escreval("5 -quantidade total de Filmes ")
escreval("6 - Encerrar")
escreval()



t <- 10

para x de 1 ate (t-1) faca



escreval("Digite a Opção Desejada")
leia(menu)


se menu = 1 entao

escreval("codigo do filme")
leia(cod[x])
escreval("Nome do filme")
leia(tit[x])
escreval("Quantidade de copias do filme")
leia(qcfil[x])

fimse

se menu = 2 entao
escreval("Codigo do Filme")
leia(cod[x])
se cod[x] <> "" entao
escreval("Escreva data de saida: ")
leia(dsai[x])
qcfil[x] <- qcfil[x] + 1

escreval("Devolver dia")
leia(ddev[x])
fimse
fimse

se menu = 3 entao
escreval("codigo do filme")
leia(cod)
escreval("Data da devolução")
leia(ddev[x])
qcfil[x]<- x - 1

fimse

se menu = 4 entao

escreval("Lista de filmes")

para x de 1 ate (t-1) faca

min <- x
para y de (x+1) ate t faca


se tit[y] < tit[min] entao

tit[min] <- tit[y]


aux1 <- tit[x]
tit[x] <- tit[min]
tit[min] <- aux1

aux <- cod[x]
cod[x] <- cod[min]
cod[min] <- aux

aux <- qcfil[x]
qcfil[x] <- qcfil[min]
qcfil[min] <- aux


para x de 1 ate t faca


escreval("Nome do filme: ",tit[x])
escreval("Codigo do filme: ",cod[x])
escreval("Quantidade disponivel: ",qcfil[x])
escreval("Locado dia",dsai[x])
escreval("Devolvido dia",ddev[x])



escreval()
escreval()
qgcfil <- qcfil[x] +1

escreval()
escreval("Total de filmes: ", qgcfil)


x <-0
x2 <- 0


fimpara
fimse
fimse
fimpara
fimpara

fimalgoritmo


Desde já agradeço a todos que puderem me ajudar e os que passarem por aqui e pelo menos tentarem, e precisando estou a disposição para ajudar no que for possivel.
Um bom dia a todos e um otimo domingo.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Video Locadora
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: