VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Calcular Multiplos

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
ADILSON HENNIG
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 38
Localização : Sidrolandia
Data de inscrição : 10/06/2009

MensagemAssunto: Calcular Multiplos   Qua Jun 10, 2009 4:57 pm

1 - construir um algoritmo que receba e um numero e escreva se é multiplo de 3 ou não. as variaveis tem de ser inteiras mas o VISUALG não aceita a divisão como inteiro
usando estrutura condicional
tentei usando de diferentes maneiras e esta foi a ultima:
var
x:inteiro
a,y,k,w:real

inicio
// Seção de Comandos
leia (x)
a<-3
y<-(x/a)
k<-(x/y)
w<-(k-x)
se w<>0 entao
escreval ("Não é Multiplo de 3")
senao
escreval ("Multiplo de 3")
fimse
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
douglas.estacio
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 37
Localização : Paracambi - RJ
Data de inscrição : 11/11/2010

MensagemAssunto: Re: Calcular Multiplos   Qui Nov 11, 2010 1:25 am

Cara, é assim:

var
num1: inteiro
inicio
escreva("Digite o número : ")
leia (num1)

se (num1 % 3 = 0) entao
escreva ("Esse número é múltiplo de 3!!!)
senao
escreva ("Não é múltiplo de 3! Favor digitar o número correto!")
fimse
fimalgoritmo

Espero q eu tenha ajudado!
Abs!!!
afro
Voltar ao Topo Ir em baixo
Ver perfil do usuário
jrlindo10
Novato
Novato
avatar

Masculino
Número de Mensagens : 11
Idade : 25
Localização : Açailandia - MA
Data de inscrição : 22/09/2010

MensagemAssunto: Re: Calcular Multiplos   Qui Nov 11, 2010 7:41 am

Usa o "MOD"

var

N: inteiro
cont: caractere

inicio

cont<- "s"
repita
leia (N)
se (N MOD 3 = 0) entao
Escreval ("número múltiplo")
senao
Escreval ("número não é múltiplo")
fimse
Escreval ("Deseja continuar? (S/N): ")
leia (cont)
ate (cont<>"S")
fimrepita
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Calcular Multiplos   

Voltar ao Topo Ir em baixo
 
Calcular Multiplos
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Resolvido] Calcular idade exata com DifData
» Não consigo calcular idade no access
» Como calcular MEDIANA e MODA
» Função calcular dias úteis
» Calcular campos de tabelas diferentes

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: