VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Vetor!! Me ajude!!

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Thiagod'Paula
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 27
Localização : DF
Data de inscrição : 12/06/2009

MensagemAssunto: Vetor!! Me ajude!!   Sex Jun 12, 2009 2:28 pm

Eu queria uma ajuda ai pra fazer um algoritmo!!
tenho q entregar esse algoritmo até domingo!
eis a situação:


José tem 1,5m de altura e cresce 2 centímetros por ano. Pedro tem 1,1m de altra e cresce 3 centímetros por ano. Construa um algortimo que calcule em quantos anos Pedro será mais alto que José.



olha o q eu fiz:



Algoritmo JOSE

Variáveis: VetA, VetJ, VetP : Vetor [1..40] de inteiro

Anos, Jose, Pedro : inteiro



Inicio

Idade <- 0

Jose<- 1,5

Pedro<- 1,1

Para(A <- 1 ate 40 passo 1) faça

Inicio

escreva(‘Digite um número’)

leia( Vet[A])

Fim-Para

Para(A <- 1 ate 40 passo 1) faça

Inicio

Se ( VetJ > VetP) então

Jose > Pedro

Senão ( VetJ < VetP) então

Pedro > Jose

Senão (VetJ = VetP) então

Jose = Pedro

Fim-se

Fim-Para

Escreva (‘Pedro vai ser maior que José após’, VetA <- VetJ = VetP,’anos’)

Fim.

Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Vetor!! Me ajude!!
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: