VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Identificar a menor e a maior nota.

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Olibetanio
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 40
Localização : Paulista-Pe
Data de inscrição : 31/05/2009

MensagemAssunto: Identificar a menor e a maior nota.   Sex Jun 12, 2009 5:15 pm

Ola gostaria de uma ajuda fiz um algoritmo usando vetores, o qual tem que digitar o nome do aluno, as notas, classificar se reprovado ou aprovado, ordenar por ordem alfabética.
E no final imprimir a menor e a maior nota.
Ps: vou colocar aqui o algoritmo até onde eu fiz.

Desde já obrigado a todos

algoritmo "Alunos"
// Função :
// Autor :
// Data : 10/6/2009
// Seção de Declarações
var
nota:vetor [1..5] de inteiro
aluno:vetor [1..5] de caracter
class:vetor [1..5] de caracter
x,min,aux2,y:inteiro
count:inteiro
aux1:caracter
inicio
// Seção de Comandos
count <- 1

enquanto count = 1 faca
para x de 1 ate 5 faca
escreva("Digite o nome do aluno: ")
leia(aluno[x])
escreva("Digite a nota do aluno ", aluno[x]," :")
leia(nota[x])
fimpara
limpatela

para x de 1 ate 5 faca
escolha nota[x]
caso 7 , 8 , 9 , 10
class[x] <- "Aprovado"
caso 6
class[x] <- "Aguadando Final"
caso 0 , 1 , 2 , 3 , 4 , 5
class[x] <- "Reprovado"
outrocaso
class[x] <- "Nota invalida"
fimescolha
fimpara

para x de 1 ate 5-1 faca
min <- x
para y de x+1 ate 5 faca
se aluno[y] < aluno[min] entao
min <- y
fimse
fimpara

aux1 <- aluno[x]
aluno[x] <- aluno[min]
aluno[min] <- aux1

aux2 <- nota[x]
nota[x] <- nota[min]
nota[min] <- aux2

aux1 <- class[x]
class[x] <- class[min]
class[min] <- aux1
fimpara
escreval("")
escreval("Alunos em ordem alfabetica")
escreval("")
para x de 1 ate 5 faca
escreval("Aluno ",aluno[x])
escreval("Nota ",nota[x])
escreval("Situação ",class[x])
escreval("")
fimpara

escreval("")
escreva("Deseja continuar 1 - sim / 2 - não? ")
leia(count)

fimenquanto
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Identificar a menor e a maior nota.
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: