VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Algoritmos com porcentagem

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Mandynhas2
Novato
Novato


Feminino
Número de Mensagens : 1
Idade : 26
Localização : curitiba
Data de inscrição : 02/09/2009

MensagemAssunto: Algoritmos com porcentagem   Qua Set 02, 2009 4:51 pm

Alguem pode me ajudar? Não consigo entender como faz para fazer o aumento desse salario Sad





A empresa XYZ decidiu conceder um aumento de salários a seus funcionários de acordo com a tabela

abaixo:

SALÁRIO ATUAL ÍNDICE DE AUMENTO

0 – 400 15%

401 – 700 12%

701 – 1000 10%

1001 – 1800 7%

1801 – 2500 4%

ACIMA DE 2500 SEM AUMENTO

Escrever um algoritmo que lê, para cada funcionário, o seu nome e o seu salário atual. Após

receber estes dados, o algoritmo calcula o novo salário e escreve na tela as seguintes informações:

<% de aumento>
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Ryudo302
Novato
Novato


Masculino
Número de Mensagens : 12
Idade : 27
Localização : Brasília, DF
Data de inscrição : 24/11/2008

MensagemAssunto: Re: Algoritmos com porcentagem   Ter Jan 26, 2010 3:06 am

Bom, primeiro você precisa de um loop (sugiro um enquanto ou um repita, mas também pode ser feito com para) para ler o nome e salário de cada funcionário e logo em seguida, ainda dentro do loop, fazer a verificação:

- Se o salário é menor ou igual a 400 (vamos ignorar o 0 já que não existe salário negativo), então o salário recebe 15% de aumento

Para fazer esse aumento, usa-se a fórmula:

X aumentado de Y% -> X + X * (Y / 100)

Ou seja:

Código:
salario <- salario + salario * (15 / 100)
// ou salario <- salario + salario * 0.15
// ou salario <- salario * 1.15

E daí só continuar, usando senao e se para cada possibilidade de salário.
Very Happy
Voltar ao Topo Ir em baixo
Ver perfil do usuário
gigante
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 26
Localização : minas gerais
Data de inscrição : 26/03/2010

MensagemAssunto: Re: Algoritmos com porcentagem   Sex Mar 26, 2010 3:27 am

nao entendi o pq de ser "salario + salario".
alguem pode me explicar?
desde ja agradeço
Voltar ao Topo Ir em baixo
Ver perfil do usuário
jrlindo10
Novato
Novato
avatar

Masculino
Número de Mensagens : 11
Idade : 25
Localização : Açailandia - MA
Data de inscrição : 22/09/2010

MensagemAssunto: Re: Algoritmos com porcentagem   Dom Nov 14, 2010 1:20 am

var

Resp, nome: caractere
salario, salario2: real

inicio
// Seção de Comandos

Resp<- "S"
Repita
Escreva ("Entre com o seu nome: ")
leia (nome)
Escreva ("Entre com o seu salário: ")
leia (salario)

se (salario<400) entao
salario2<- (salario * 0.15)
senao
se (salario>400) e (salario<700) entao
salario2<- (salario * 0.12)
senao
se (salario>700) e (salario<1000) entao
salario2<- (salario * 0.10)
senao
se (salario>1000) e (salario<1800) entao
salario2<- (salario * 0.07)
senao
se (salario>1800) e (salario<2500) entao
salario2<- (salario * 0.04)
senao
salario<- salario
fimse
fimse
fimse
fimse
fimse


Escreval (nome, " o seu novo salário é de: ", salario2+salario)
Escreval ("")
Escreva ("Deseja continuar (S/N)?: ")
leia (Resp)
Escreval ("")
ate (Resp<>"S")

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Algoritmos com porcentagem   

Voltar ao Topo Ir em baixo
 
Algoritmos com porcentagem
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Como cria uma barra de warn com porcentagem
» Av - Logicando: Praticando Algoritmos
» Respostas das oito questões do ENADE algoritmos e programação
» calcula porcentagem no vba
» [Resolvido]Calculo de porcentagem em contas a receber

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: