VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 posto de gasolina e alcool

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
daniell
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 25
Localização : serrinha
Data de inscrição : 04/09/2009

MensagemAssunto: posto de gasolina e alcool   Sab Set 05, 2009 12:17 am

Um posto está vendendo combustíveis com a seguinte tabela de descontos:
Álcool:até 20 litros, desconto de 3% por litro.
  acima de 20 litros, desconto de 5% por litro.

Gasolina:até 20 litros, desconto de 4% por litro.
  acima de 20 litros, desconto de 6% por litro.

Faça um algoritmo que leia o número de litros vendidos, o tipo de combustível (codificado da seguinte forma: A-alcool, G-gasolina), calcule e imprima o valor a ser pago pelo cliente sabendo-se que o preço da gasolina é de R$ 1,20 o litro e o álcool  R$ 0,90.

algoritmo "posto de gasolina e alcool"
// Função : incompleta
// Autor : Daniel
// Data : 4/9/2009
// Seção de Declarações 
var
alcool, gasolina, c ,a : logico
q : real
inicio
// Seção de Comandos
escreva ("tipo de combustivel:")
leia(c)
se (c = a) entao
escreva ("Quatidade de combustivel em litros:")
leia(q)
se (q <= 20) entao
escreva ("valor a pagar: R$", 0.90 * q - (q * 0.3))
senao
escreva ("valor a pagar: R$", 0.90 * q - (q * 0.5))
fimse
fimse
fimalgoritmo

Como eu faço para diferenciar, de quando for alcool e quando for gasolina?tipo, se (combustivel = gasolina) ou = alcool Entao
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Ryudo302
Novato
Novato


Masculino
Número de Mensagens : 12
Idade : 27
Localização : Brasília, DF
Data de inscrição : 24/11/2008

MensagemAssunto: Re: posto de gasolina e alcool   Ter Jan 26, 2010 2:51 am

Eu faria essas alterações:

Código:
algoritmo "posto de gasolina e alcool"
// Função : incompleta
// Autor : Daniel
// Data : 4/9/2009
// Seção de Declarações
var
  comb : caractere
  q : real
inicio
// Seção de Comandos
  escreva ("tipo de combustivel ('A' para álcool ou 'G' para gasolina):")
  leia(comb)
  se (comb = 'A') entao // álcool
      escreva ("Quatidade de combustivel em litros:")
      leia(q)
      se (q <= 20) entao
        escreva ("valor a pagar: R$", 0.90 * q - (q * 0.3))
      senao
        escreva ("valor a pagar: R$", 0.90 * q - (q * 0.5))
      fimse
  senao
      se (comb = 'G') entao // gasolina
        ... // aqui vc completa com o que acontece se for gasolina
      senao
        escreva ("Opção inválida!")
      fimse
  fimse
fimalgoritmo

E tente utilizar escreval ao invés de escreva, pois ele imprime a mensagem e pula uma linha, facilitando a visualização.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
posto de gasolina e alcool
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: