VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Algoritmo Melhor aluno!

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Rodivan
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 26
Localização : Rolim de Moura
Data de inscrição : 10/09/2009

MensagemAssunto: Algoritmo Melhor aluno!   Ter Out 06, 2009 11:59 am

Pessoal estou com uma dúvida nesse algoritmo, onde eu tenho q saber a melhor nota do aluno e o nome desse aluno. No meu algoritmo ta saindo assim mas ele só da a última nota como maior mesmo declarando uma nota baixa. Saiu assim:

algoritmo "Melhor_Aluno"
// Função : Exibir a nota maxima e o nome do aluno
// Autor : Rodivan Veríssimo
// Data : 6/10/2009
Var
Nota, Max, Quant, Contador :Inteiro
Nome, Melhor :Literal
Inicio
Escreva ("Entre com a quantidade de alunos: ")
Leia (Quant)
Max <- -1
Contador <- 0//O comando Repita procede a leitura da nota do aluno
Repita
Escreva ("Entre com o nome do aluno: ")
Leia (Nome)
Escreva ("Digite a nota do aluno (valor de 0 a 10 ): ")
Leia (Nota)
Contador <- Contador + 1
Ate Contador = Quant
Se Nota > Max Entao
Max <- Nota
Melhor <- Nome
FimSe
Escreva ("Melhor aluno: " ,Melhor,", com a nota ",max)
fimalgoritmo

Se alguem puder me ajudar!! Grato!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
/dev/head
Novato
Novato
avatar

Masculino
Número de Mensagens : 8
Idade : 23
Localização : São Paulo
Data de inscrição : 14/09/2009

MensagemAssunto: Re: Algoritmo Melhor aluno!   Sex Out 16, 2009 9:04 pm

Olha eu refiz o seu algoritimo olha como ficou espero que seja de bom uso

algoritmo "Melhor_Aluno"
// Função : Exibir a nota maxima e o nome do aluno
// Autor : /Dev/Head
// Data : 16/10/2009
Var
Nota, Max,i, Quant :Inteiro
Nome, Melhor :caracter
Inicio
Escreva ("Entre com a quantidade de alunos: ")
Leia (Quant)
Max <- 0
limpatela
para i de 0 ate (quant-1) faca
Escreva ("Entre com o nome do aluno: ")
Leia (Nome)
Escreva ("Digite a nota do aluno (valor de 0 a 10 ): ")
Leia (Nota)
limpatela
Se (Nota > Max) Entao
Max <- Nota
Melhor <- Nome
FimSe
fimpara
Escreva ("Melhor aluno: " ,Melhor,", com a nota ",max)

fimalgoritmo


Até /Dev/Head
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://devhead.4shared.com
Rodivan
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 26
Localização : Rolim de Moura
Data de inscrição : 10/09/2009

MensagemAssunto: Re: Algoritmo Melhor aluno!   Qui Out 22, 2009 1:21 pm

Valeu! Deu certinho, Obrigado!! Está funcionando!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Algoritmo Melhor aluno!   

Voltar ao Topo Ir em baixo
 
Algoritmo Melhor aluno!
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Doação [Da Minha Melhor Borda Modelada]
» O melhor do PS1
» O melhor vocalista!
» Cuidados a ter para melhor proteger o seu veículo dos elementos
» Capacetes ( Qual a melhor relação Preço/Qualidade )

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: