VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Como "Criar" um arquivo de texto pelo visualg

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
/dev/head
Novato
Novato
avatar

Masculino
Número de Mensagens : 8
Idade : 23
Localização : São Paulo
Data de inscrição : 14/09/2009

MensagemAssunto: Como "Criar" um arquivo de texto pelo visualg   Qui Out 29, 2009 4:44 pm

por exemplo voce quer fazer um cadastro de uma pessoa, primeiro digite o local que voce quer que o arquivo seja salvo mas ESSE ARQUIVO NAO PODERÁ EXISTIR neste local mas o NOME do arquivo que voce quer que ele seja salvo deverá seer digitado.

veja o exemplo :


algoritmo "Criador de arquivo"
//primeiro digite o diretorio e o nome do arquivo lembrando que ele nao pode existir neste diretorio
arquivo "C:\Documents and Settings\USER\Desktop\pessoas.txt"
// no seu desktop por exemplo nao podera ter esse arquivo porque o visualg "cria" ele pra voce
// Função : gravar registros dentro do arquivo
// Autor : /dev/head
// Data : 28/10/2009
// Seção de Declarações
var
vcodigo : vetor[1..10] de caracter
vnome : vetor[1..10] de caracter
vidade : vetor[1..10] de caracter
vtelefone : vetor[1..10] de caracter
i : inteiro
inicio
// Seção de Comandos
para i de 1 ate 3 faca
escreva ("Entre com o codigo: ")
leia (vcod[i])
escreva ("entre com o nome da pessoa: ")
leia (vnome[i])
escreva ("entre com a idade da pessoa: ")
leia (vidad[i])
escreva ("entre com o telefone da pessoa: ")
leia (vtele[i])
limpatela
fimpara
escreval (" Fim de cadastro !!")


fimalgoritmo

depois disso abra o arquivo para ve-lô

espero que seja util
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://devhead.4shared.com
 
Como "Criar" um arquivo de texto pelo visualg
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Criar uma caixa para inserir texto
» Como posso criar um tema pro meu fórum?
» Queria saber se tem como eu criar uma página de login diferente
» Como posso criar um tema para o meu fórum?
» Como posso criar temas para meus fóruns

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Suporte-
Ir para: