VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Problema no algoritmo

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
carlos_ph
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 25
Localização : Palhoça
Data de inscrição : 15/11/2009

MensagemAssunto: Problema no algoritmo   Dom Nov 15, 2009 3:06 pm

fazer um algoritmo que leia os nomes e as notas de 20 alunos em 4 disciplinas. A seguir calcule e imprima a media semestral do aluno e a media da turma. O algoritmo deve ainda informar qual o aluno com maior media e o aluno com menor media.

to com problema em mostra o aluno com maior e menor media

var
nome:caracter
x,y:real
i:inteiro
vet:vetor[1..4] de inteiro

inicio
para i<-1 ate 20 passo 1 faca
Escreval("qual o nome do aluno?")
leia(nome)
para i<-1 ate 4 passo 1 faca
escreval("qual a media de ",nome," na ",i,"ª materia?")
leia(vet[i])
x<-x+vet[i]
y<-y+vet[i]
fimpara
x<-x/4
escreval("Media semestral de ",nome,": ",x)
x<-0
fimpara
y<-(y/4)/20
escreval("Media da turma: ",y)

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
carlos_ph
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 25
Localização : Palhoça
Data de inscrição : 15/11/2009

MensagemAssunto: Re: Problema no algoritmo   Ter Nov 17, 2009 11:02 am

consegui resolver

var
nome,nmaior,nmenor:caracter
x,y:real
i,l,maior,menor:inteiro
vet:vetor[1..4] de inteiro
inicio
x<-0
para i<-1 ate 20 passo 1 faca
Escreval("qual o nome do aluno?")
leia(nome)
para l<-1 ate 4 passo 1 faca
escreval("qual a media de ",nome," na ",l,"ª materia?")
leia(vet[i])
x<-x+vet[i]
y<-y+vet[i]
se (maior
maior<-vet[i]
menor<-maior -1
nmaior<-nome
fimse
se (menor>=vet[i]) entao
menor<-vet[i]
nmenor<-nome
fimse
fimpara
x<-x/4
escreval("Media semestral de ",nome,": ",x)
x<-0
fimpara
y<-(y/4)/20
escreval("Media da turma: ",y)
escreval("Aluno ",nmaior," tem a maior media: ",maior)
escreval("Aluno ",nmenor," tem a menor media: ",menor)
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Problema no algoritmo
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Grande problema a 2T
» Problema com Vapor da Trailtech
» Problema de cor de legenda e cores, de Admin, menbros..etc
» Problema com a imagem do rank
» Código com problema

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: