VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 DUVIDA VETOR

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
FERNANDO SANTOS
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 32
Localização : salvador
Data de inscrição : 04/12/2009

MensagemAssunto: DUVIDA VETOR   Sab Dez 05, 2009 12:27 am

Criar
um algoritmo onde deve ler 100 números. Armazenar os números pares em um VETOR1 e os ímpares
em um VETOR 2.


var
n,par,impar:vetor[1..5] de inteiro
B,a,x:inteiro
inicio


para a de 1 ate 5 faca
escreval("informe o numero")
leia(n[a])
FIMPARA
para x de 1 ate 5 faca
se n[x] MOD 2= 0 entao
PAR[X]:=n[X]
senao
impar[x]:=n[x]
fimse
fimpara

escreval(par[1],par[2],par[3],par[4],par[5]

escreval(impar[1],impar[2],impar[3],impar[4],impar[5])

gostaria de alocar os numeros de forma que se for par, vetor impar não variasse do mesmo modoque se numer=impar vetor par não variasse
Exemplo: neste algoritmo acima se eu digitar respectivamente:1,2,3,4,5
irá exibir: vetor par= 0,2,0,4,0 e não 2,4,0,0,0
vetor impar = 1,0,3,0,5 e não 1,3,5,0,0
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Ryudo302
Novato
Novato


Masculino
Número de Mensagens : 12
Idade : 27
Localização : Brasília, DF
Data de inscrição : 24/11/2008

MensagemAssunto: Re: DUVIDA VETOR   Sex Jan 22, 2010 4:29 am

Para fazer o desejado, eu criaria mais três variáveis inteiras, duas contadoras: uma para os pares e outra para os ímpares; e uma auxiliar.

Código:
var
contPar, contImpar, aux : inteiro

Contadoras iniciadas com 0

Código:
contPar <- 0
contImpar <- 0

E aí, a cada leitura de número você já ía verificando cada um e armazenando conforme o caso:

Código:
leia (aux)
se aux é par entao
  par[contPar] <- aux
  contPar <- contPar + 1
senao
  ... // mesma coisa para ímpares
fimse

Daí só resta exibir os vetores. Se der certo, quando você digitar, por exemplo, { 1 2 3 4 5 }, aparecerá:

2,4,0,0,0
1,3,5,0,0


Smile
Voltar ao Topo Ir em baixo
Ver perfil do usuário
FERNANDO SANTOS
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 32
Localização : salvador
Data de inscrição : 04/12/2009

MensagemAssunto: Re: DUVIDA VETOR   Sex Jan 22, 2010 6:13 pm

Obrogado pelo post
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: DUVIDA VETOR   

Voltar ao Topo Ir em baixo
 
DUVIDA VETOR
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Vetor] Retro Stars
» Meu vetor - Desenho
» [DUVIDA] Teria como colocar Boot para punbb
» Duvida com submenu
» Duvida - menu em html

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: