VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 algoritmo nao roda

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
quequis
Novato
Novato


Feminino
Número de Mensagens : 1
Idade : 35
Localização : Belo Horizonte
Data de inscrição : 26/05/2010

MensagemAssunto: algoritmo nao roda   Qua Maio 26, 2010 9:58 pm

Faça um algoritmo com matriz
para ler nome, quantidade de faltas e as três notas de todos os alunos da
turma. Após a leitura de todos os dados
faça:


- calculo da média de cada aluno



- mostre o nome dos alunos
aprovados, sendo que para isto é necessário que a média seja maior ou igual a
7.0 e a quantidade de faltas seja menor que 4.
Pessoal, eu ja fiz de tudo para esse algoritmo rodar e nao consigo,alguem pode me ajudar por favor

Code
algoritmo "semnome"
// Função :
// Autor :
// Data : 26/5/2010
// Seção de Declarações
var
NOME:vetor[100]de literal
Faltas:vetor[100]inteiro
NOTAS:vetor[0..100,0..4]de real
LINHA,COLUNA,N: inteiro
MEDIA:real

inicio
{leitura dos dados}
escreva "Digite a quantidade dos alunos:"
leia N

para LINHA de 0 ate 99 passo 1 faça;
escreva "Digite nome:";
leia NOME[LINHA];
escreva "Digite quantidade de faltas:"
leia FALTAS[LINHA];

para COLUNA de 0 ate 4 passo 1 faça;
escreva"Digite as tres notas:"
leia NOTAS[COLUNA];
fim-para


fim-para
para LINHA de 0 ate 99 passo 1 faça
MEDIA[LINHA]<-(NOTA1[LINHA]+NOTA2[LINHA]+NOTA3[LINHA]/3

fim-para

escreva"Alunos aprovados:"
para COLUNA de 0 ate 4 passo 1 faça
se (MEDIA[LINHA]>=7.E.(FALTAS[LINHA]<4) entao
escreva "NOME:"NOME[LINHA]
fim-se

fim-para


fimalgoritmo


Obrigada
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
algoritmo nao roda
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Roda xr 400
» Roda 18"
» Compro Roda 18 Polegadas para CRF
» roda de tras 19
» O meu widget de topicos recentes não roda

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Suporte-
Ir para: