VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 MI AJUDA COM ESSES ALGORITMOS AI PELO AMOR DE DEUS

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Smith
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 25
Localização : rio de janeiro
Data de inscrição : 23/06/2010

MensagemAssunto: MI AJUDA COM ESSES ALGORITMOS AI PELO AMOR DE DEUS    Qua Jun 23, 2010 4:29 pm

1) Escreva um algoritmo que leia três números inteiros e positivos (A, B, C) e calcule a seguinte expressão:D=R+S /2 , onde R=(A+B)² e S=(B+C)² .

2) Faça um algoritmo que leia a matrícula do funcionário, o número de horas trabalhadas mensais, o valor que recebe por hora e o número de filhos com idade menor de 14 anos. Calcular e escrever o salário deste funcionário, sendo que cada filho menor de 14 anos acrescenta 10% do salário.

3) O custo ao consumidor de um carro novo é a soma do custo de fábrica com a percentagem do distribuidor e dos impostos (aplicados ao custo de fábrica). Supondo que a percentagem do distribuidor seja de 28% e os impostos de 45%, escrever um algoritmo que leia o custo de fábrica de um carro e escreva o custo ao consumidor.


Não to conseguindo fazer isso rodar por nada...
No No
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Vampeld
Novato
Novato


Masculino
Número de Mensagens : 5
Idade : 26
Localização : Minas Gerais
Data de inscrição : 24/09/2010

MensagemAssunto: Re: MI AJUDA COM ESSES ALGORITMOS AI PELO AMOR DE DEUS    Ter Set 28, 2010 7:53 pm

1.

algoritmo "calcular"
// Função : Calculos
// Autor : André Malkavian
// Data : 28/9/2010

// Seção de Declarações
var
a,b,c,d,r,s : real

inicio
// Seção de Comandos
//Ler os tres numeros
Escreval("Digite os três numeros inteiros positivos:")
leia (a,b,c)

r <- (a + b)^2
s <- (b + c)^2
d <- (r + s) /2
Escreval (" D é igual a:", d)

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Vampeld
Novato
Novato


Masculino
Número de Mensagens : 5
Idade : 26
Localização : Minas Gerais
Data de inscrição : 24/09/2010

MensagemAssunto: Re: MI AJUDA COM ESSES ALGORITMOS AI PELO AMOR DE DEUS    Ter Set 28, 2010 8:35 pm

2.

algoritmo "calcsal+add"
// Função : Calcular salário
// Autor : André Malkavian
// Data : 28/9/2010
// Seção de Declarações
var
mat, num_filhos: inteiro
htrab, val_hora, sal, nsal, addsal: real



inicio
// Seção de Comandos
Escreval ("Digite a matricula do funcionário")
leia (mat)
Escreval ("Digite a quantidade de horas trabalhadas no mês:")
leia (htrab)
Escreval ("Digite o valor da hora trabalhada:")
leia (val_hora)
Escreval ("Digite a quantidade de filhos menores de 14 anos que ele possui")
leia (num_filhos)
sal <- htrab * val_hora
addsal <- (num_filhos * 0.1) * sal
nsal <- sal + addsal
Escreval ("O Salário do funcionário de matricula", mat, " é de R$", nsal," reais.")






fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Vampeld
Novato
Novato


Masculino
Número de Mensagens : 5
Idade : 26
Localização : Minas Gerais
Data de inscrição : 24/09/2010

MensagemAssunto: Re: MI AJUDA COM ESSES ALGORITMOS AI PELO AMOR DE DEUS    Ter Set 28, 2010 8:55 pm

3.

algoritmo "calcvalcar+add"
// Função : Calcular valor de automovel com add
// Autor : André Malkavian
// Data : 28/9/2010
// Seção de Declarações
var
custcons, reajust, custfab: real
inicio
// Seção de Comandos
Escreval ("Escreva o Custo de Fábrica do Automóvel:")
leia (custfab)
reajust <- custfab * (0.28 + 0.45)
custcons <- custfab + reajust
Escreval (" Custo ao consumidor: R$", custcons,",00 ")
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: MI AJUDA COM ESSES ALGORITMOS AI PELO AMOR DE DEUS    

Voltar ao Topo Ir em baixo
 
MI AJUDA COM ESSES ALGORITMOS AI PELO AMOR DE DEUS
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: