VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 media das idades

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
nana43
Novato
Novato


Feminino
Número de Mensagens : 1
Idade : 46
Localização : brasilia
Data de inscrição : 12/09/2010

MensagemAssunto: media das idades   Dom Set 12, 2010 6:23 pm

Pessoal sou nova aqui no forum e sou aprendiz de algoritmos portanto gostaria de pedir a ajuda de voces para este algoritmo.

a partir de um conjunto de dados contendo a altura e o sexo (masculino, feminino) com 10 pessoas .Crie um algoritmo que calcuel e escreva :
.a maior altura do grupo
.a media de altura das mulheres
.o mumero de homens


algoritmo mediaDas Idades

var
altura:real
menorAltura:real
maiorAltura:real
sexo:caracter
qtdePessoas:inteiro
contM, contF: inteiro
mediaAlturaMulheres:real
f,m caracter

inicio

escreval("informe a primeira altura")
leia(altura)
menorAltura <- altura
maiorAltura <- altura
f <- sexo
m<- sexo
contF <- 0
comtM <- 0
para qtdePessoas de 1 ate 10 faca
escreval("Entre com a":,qtdePessoas, altura e sexo")
leia(altura)
leia(sexo)
se altura > maiorAltura entao
maiorAltura <- altura
fimse
se altura < menorAltura entao
menor <- altura
fimse
se (sexo == f) entao
contF <- contF + 1
senao
contM <- contM + 1
fimse
fimpara
mediaAlturaMulheres <- (mediaAlturaMulhres + altura)/contF
escreval("A maior altura é:", maiorAltura)
escreval("A menor altura é:", menorrAltura)
escreval("A media de altura das mulheres é:", mediaAlturaMulheres)
escreval("A qtde de homens é:", contM)

Ate a maior e e menor idade tudo bem, o visualg me retorna o valor correto, mas quanto a media de idade das mulhere e qtde de homens, não me devolve valor correto.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
media das idades
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Go Media Arsenal - Complete Photoshop Brush Sets 1-14
» Expandir o Game Maker com essa LIB de media player
» Colocar media player
» BBcode media
» Problema com o Media Player Classic

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: