VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Problemão com esse algoritmo - preciso de dicas!!!

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Higino Perotti Neto
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 26
Localização : cwb
Data de inscrição : 14/09/2010

MensagemAssunto: Problemão com esse algoritmo - preciso de dicas!!!   Ter Set 14, 2010 2:46 pm

Escrever um algoritmo que lê 3 comprimentos de lado (A,B e C) e os ordena em
ordem decrescente, de modo que o lado A representa o maior dos 3 lados. A seguir, determine o tipo de triângulo que estes três lados forma, com base nos seguintes casos,
sempre escrevendo uma mensagem adequada:
- se A > B+C, não formam triângulo algum
- se A2 = B2 + C2, então formam triângulo retângulo
- se A2 > B2 + C2, então formam triângulo obtusângulo
- se A2 < B2 + C2, então formam triângulo acutângulo
- se A = B = C, então formam triângulo equilátero
- se dois dos lados forem iguais, então forma um triângulo isósceles




tentei fazer e ficou assim:

algoritmo "Exe_12_lista2"
// Autor : Higino Perotti Neto
// Data : 13/9/2010
var
A,B,C: inteiro
inicio
escreval

escreva("Digite um valor para o lado A: ")
leia(A)
escreva("Digite um valor para o lado B: ")
leia(B)
escreva("Digite um valor para o lado C: ")
leia(C)

se A > B+C entao
escreval("Triângulo Retângulo")
fimse

se A =B+C entao
escreval("Triângulo Obtusângulo")
fimse

se A < B+C entao
escreval("Triângulo Acutângulo")
fimse

se (A=B)ou(A=C)ou(A=C)entao
escreval("Triângulo Isósceles")
fimse

fimalgoritmo


Voltar ao Topo Ir em baixo
Ver perfil do usuário
jakons
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 27
Localização : Gramado RS
Data de inscrição : 17/11/2010

MensagemAssunto: Re: Problemão com esse algoritmo - preciso de dicas!!!   Qua Nov 17, 2010 8:45 am

primeiro você tem quem dar uma ordenação que você não fez ainda, eu tb estou neste exercicio mas ainda não consegui acabar, mas aqui vai uma dica do que tenho até agora.
__________________________

Citação :
algoritmo "Triangulos"
// Função : NOthing
// Autor : Jakson Juliano Fischer Pinto
// Data : 11/16/2010
// Seção de Declarações
var
a, b, c :inteiro
inicio
escreva ("Valor para A: ")
leia (a)
escreva ("Valor para B: ")
leia (b)
escreva ("Valor para C: ")
leia (c)
se (a > b) e (b > c) entao
escreva (a,",",b,",",c)
senao
se (b > a) e (a > c) entao
escreva (b,",",a,",",c)
senao
se (c > b) e (b > a) entao
escreva (c,",",b,",",a)
senao
se (a > c) e (c > b) entao
escreva (a,",",c,",",b)
senao
se (b > c) e (c > a) entao
escreva (b,",",c,",",a)
senao
se (c > a) e (a > b) entao
escreva (c,",",a,",",b)
fimse
fimse
fimse
fimse
fimse
fimse
se (a > b) e (a > c) entao
escreva (a)
fimse
// Seção de Comandos
fimalgoritmo
espero que tenha ajudado que seja um pouco, assim que eu conseguir resolver irei postar mais ou o exercicio completo, mas te digo, a melhor forma de aprender é se quebrando hehehe
Voltar ao Topo Ir em baixo
Ver perfil do usuário
jakons
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 27
Localização : Gramado RS
Data de inscrição : 17/11/2010

MensagemAssunto: Re: Problemão com esse algoritmo - preciso de dicas!!!   Qua Nov 17, 2010 9:52 am

como te disse assim que terminasse o mesmo estaria postando aqui para ti
talvez tenham algums pequenos erros mas isto você mesmo poderá corrigir.
___
algoritmo "Triangulos"
// Função : NOthing
// Autor : Jakson Juliano Fischer Pinto
// Data : 11/16/2010
// Seção de Declarações
var
a, b, c :inteiro
rec :numerico
inicio
escreva ("Valor para A: ")
leia (a)
escreva ("Valor para B: ")
leia (b)
escreva ("Valor para C: ")
leia (c)
escreval ("")
escreval ("Números ordenados de forma Decrescente: ")
se (a > b) e (b > c) entao
escreval (a,",",b,",",c)
senao
se (b > a) e (a > c) entao
escreval (b,",",a,",",c)
senao
se (c > b) e (b > a) entao
escreval (c,",",b,",",a)
senao
se (a > c) e (c > b) entao
escreval (a,",",c,",",b)
senao
se (b > c) e (c > a) entao
escreval (b,",",c,",",a)
senao
se (c > a) e (a > b) entao
escreval (c,",",a,",",b)
senao
se (a = b) e (b = c) entao
escreval (a,",",b,",",c)
senao
se (a > b) e (b = c) entao
escreval (a,",",b,",",c)
senao
se (b > c) e (a = c) entao
escreval (b,",",a,",",c)
senao
se (c > a) e (b = a) entao
escreva (c,",",a,",",b)
fimse
fimse
fimse
fimse
fimse
fimse
fimse
fimse
fimse
fimse
escreval ("")
se (a > b) e (a > c) entao
//escreval (a)
a := a
senao
se (b > a) e (b > c) entao
//escreval (b)
a := b
senao
se (c > a) e (c > b) entao
//escreval (c)
a := c
fimse
fimse
fimse
se (a > b + c) entao
escreva ("Não formam triangulo algum")
senao
se (a * a = b * b + c * c) entao
escreva ("Formam um triangulo retângulo")
senao
se (a * a > b * b + c * c) entao
escreva ("Forma um triângulo obtusângulo")
senao
se (a = b) e (b = c) e (a = c) entao
escreva ("Formam um triângulo Equilátero")
senao
se (a * a < b * b + c * c) entao
escreva ("Formam um triângulo ocutângulo")
senao
se (a = b) e (a <> c) entao
escreva ("Formam um triângulo isósceles")
senao
se (b = c) e (b <> a) entao
escreva ("Formam um triângulo isósceles")
senao
se (c = a) e (c <> b) entao
escreva ("Formam um triângulo isósceles")
fimse
fimse
fimse
fimse
fimse
fimse
fimse
fimse
// Seção de Comandos
fimalgoritmo
___

Espero ter ajudado.
Até
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Problemão com esse algoritmo - preciso de dicas!!!   

Voltar ao Topo Ir em baixo
 
Problemão com esse algoritmo - preciso de dicas!!!
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» ME AJUDEM POR FAVOR, NÃO TO COMPREENDENDO ESSE ALGORITMO
» Preciso de dicas.
» Amigo preciso centralizar esse rank veja
» Preciso da ajuda na resolução deste exercicios não resolvidos de Algoritmo! Socorro
» [Dica]Dicas Sobre Tipografia

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: