VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 [b]Me ajudem , estou com dificuldade em fazer esse algoritmo

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Lucas William Casale
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 24
Localização : Jundiai
Data de inscrição : 02/10/2010

MensagemAssunto: [b]Me ajudem , estou com dificuldade em fazer esse algoritmo   Sab Out 02, 2010 1:30 am

Faça um algoritmo que leia um valor x e uma valor n . Calcule e exiba y= x-2x+4x-6x+8x-10x+... NX
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Lucas Luiz
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 22
Localização : Por Indicação
Data de inscrição : 08/10/2010

MensagemAssunto: Re: [b]Me ajudem , estou com dificuldade em fazer esse algoritmo   Sex Out 08, 2010 9:26 pm

De Lucas pra Lucas !
Cara, para treinar eu fiz um algoritmo,
pode ser que esteja certo,
mas na próxima vez coloque o seu algoritmo aqui
para podermos tirar suas dúvidas.
Um abraço


algoritmo "semnome"
// Função :
// Autor :
// Data : 8/10/2010
// Seção de Declarações
// Faça um algoritmo que leia um valor x e uma valor n . Calcule e exiba y= x-2x+4x-6x+8x-10x+... NX
var
Y, X, N:INTEIRO
VEZES : INTEIRO

inicio
// Seção de Comandos

escreva("DIGITE N (CASO QUEIRA SAIR, DIGITE 0) ")
LEIA(N)
enquanto N > 0 FACA
escreva("DIGITE X ")
LEIA(X)
para VEZES de 1 ate N faca
SE (VEZES MOD 2)=0 ENTAO
Y:=Y+VEZES*X
FIMSE
fimpara
y:=x-y
escreva("RESULTADO:")
escreva(Y)
escreval
escreval
escreva("DIGITE N (CASO QUEIRA SAIR, DIGITE 0) ")
LEIA(N)
fimenquanto
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
[b]Me ajudem , estou com dificuldade em fazer esse algoritmo
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Como fazer esse tipo de campos de perfil?
» Como fazer esse efeto
» [Resolvido] Como fazer esse forum/menu assim?
» Como fazer esse menu?
» Como fazer esse quadro?

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: