VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Ajuda - Soma de vetores

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
iceman
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 28
Localização : -
Data de inscrição : 15/10/2010

MensagemAssunto: Ajuda - Soma de vetores   Sex Out 15, 2010 9:23 pm

Boa noite a todos.

Estou com dificuldades em desenvolver um programa que leia 2 matrizes A e B, cada um com 15 elementos. Construir uma matriz C, onde nessa deverá ser a junção dos elemento da matriz A e da matriz B, ou seja, 30 elemento na matriz C.

Fiz um pelo visualg, mas parece que não está dando certo:


algoritmo "semnome"
// Função :
// Autor : fulano
// Data : 15/10/2010
// Seção de Declarações
var
A,B:vetor [1..15] de inteiro
C:vetor[1..30] de inteiro
I:inteiro
inicio
para I de 1 ate 15 faca
Escreva ("Digite o",I,"numero do vetor A: ")
Leia (A[I])
fimpara

limpatela

para I de 1 ate 15 faca
Escreva ("Digite o",I,"numero do vetor B: ")
Leia (B[I])
fimpara

limpatela

para I de 1 ate 30 faca
se (A[I] < B[I]) entao
C[I] <- A[I]
senao
C[I] <- B[I]
Escreva (C[I])
fimse
fimpara
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Ajuda - Soma de vetores
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Vetores] Music Set
» Gráficos ?! Qual editor vocês usam pra Vetores ?!
» Ajuda com ranks
» Me ajuda aqui por favor
» Ajuda com rank

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: