VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Ajuda para algoritmos basicos

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
caiqueeeee
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 27
Localização : Guarulhos
Data de inscrição : 30/10/2010

MensagemAssunto: Ajuda para algoritmos basicos   Sab Out 30, 2010 12:16 pm

vou ter uma prova proxima semana e tenho 20 exercicios para estudar estou fazendo os outros 16 em grupo e gostaria de ajuda nesses 4 de baixo para ja adiantar a entrega do portifolio.
Obrigado a quem ajudar.

1. Faça um algoritmo que receba o salário de um funcionário chamado Carlos. Sabe-se que o funcionário
João tem um salário equivalente a um terço do salário de Carlos. Carlos aplicará seu salário
integralmente na caderna de poupança, que está rendendo 2% ao mês e João aplicará seu salário
integralmente no fundo de renda fixa, que está rendendo 5% ao mês. Calcule e mostre a quantidade de
meses necessários para que o valor pertencente a João iguale ou ultrapasse o valor pertencente a
Carlos.
2. Dados um número inteiro positivo n e uma seqüência de n números inteiros. Faça um algoritmo que
calcule a soma dos números negativos e a soma dos números positivos da seqüência.
3. Dados dois números inteiros positivos x e n, faça um algoritmo que calcule x n .
4. Dados um número inteiro positivo n e uma seqüência de n números inteiros. Faça um algoritmo que
ache o menor número da seqüência.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ADELSON
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 28
Localização : São Paulo
Data de inscrição : 08/12/2010

MensagemAssunto: Re: Ajuda para algoritmos basicos   Sab Dez 11, 2010 9:09 am

algoritmo "semnome"
// Função :
// Autor :
// Data : 08/12/2010
// Seção de Declarações
var
sfun1, sfun2: real//Sálários dos dois funcionários
rendafun1, rendafun2: real //renda mensal com juros
i:real//contador de porcentagem p/ fun1
i2: real//contador de porcentagem p/ fun2

meses2:real//quantidade de meses
mes : real // contagem de meses: "1º,2º,3ºmes....."
fun1, fun2: caractere// nome dos dois funcionários
r1, r2: real//salário final(com o juro já imbutido)
inicio
// Seção de Comandos
escreval("A seguir temos a demonstração de dois valores aplicados em diferentes")
escreval(" taxas de juro. o objetivo é saber com quantos meses o menor salário ")
escreval("irá ultrapassar o maior salário, já que o juro do menor salário será mais alto ")
escreval("que o juro do maior salário:")
escreval("")

escreval("Nome do funcionário de maior salário")
leia (fun1)
escreval("Digite o salário de " ,fun1)
leia(sfun1)
escreval("o juro que correrá o Dinheiro de ",fun1)
leia (j)
ESCREVAL ("Nome do funcionário de menor salário")
leia(fun2)

repita
escreval ("Digite o salário de ",fun2 )
leia(sfun2)
se sfun2 >= sfun1 entao
escreval("Dado incorreto. O valor informado é maior que o salário de ", fun1)
fimse
ate sfun2 < sfun1
fimrepita

repita
escreval ("o juro que correrá o Dinheiro de ",fun2)
leia(j2)
se j2 <= j entao
escreval("O juro do menor salário deve ser maior que o juro do maior salário" )
fimse
ate j2 > j
fimrepita

i <- j/100
rendafun1 <- sfun1 * i
i2 <- j2/100
rendafun2 <- sfun2 * i2

r1 <- sfun1
r2 <- sfun2
mes <- 0

enquanto r2 < r1 faca
r1 <- r1 + rendafun1
r2 <- r2 + rendafun2
MES <- MES + 1
escreva(fun2," ",MES,"º mês ",r2)
escreval (" ",fun1," ",mes,"º mês ",r1 )
fimenquanto

meses2 <- (r2 - sfun2)/rendafun2
escreval(meses2," mes(es) para o salário do SR ",fun2," ultrapassar o salário do " )
escreval (" SR ",fun1)

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
ADELSON
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 28
Localização : São Paulo
Data de inscrição : 08/12/2010

MensagemAssunto: Re: Ajuda para algoritmos basicos   Sab Dez 11, 2010 9:21 am

sou novo no forum, mas vi sua dúvida e fiz o algarítimo do salário.
espero ter ajudado, apesar de sua prova ja ter sido aplicada, talvez ainda tivesse
alguma dúvida. outra coisa, não da para fazer com um valor fixo da taxa de juros (5% e 2%), assim o resultado seria sempre o mesmo
independentimente do valor do salário. por isso deixei a disposição do usuário a entrada de todos os dados como nome dos funcionários,
juros e valor do salário de cada um com a regra de que o 1º salário sempre seja maior que o segundo.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
luizbellow
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 26
Localização : Brasil
Data de inscrição : 12/10/2012

MensagemAssunto: algoritmo "calc" // Função : calcular // Autor : luiz // Da   Sex Out 12, 2012 4:15 pm

algoritmo "calc"
// Função : calcular
// Autor :
// Data : 11/10/2012
// Seção de Declarações
var
sal_car, sal_jo, meses, rend_car, rend_jo, cont : real


inicio
// Seção de Comandos
escreval("Informe o salário do Sr. Carlos:")
leia(sal_car)
sal_jo <- sal_car/3
rend_car <-sal_car/100*2
rend_jo <-sal_jo/100*5
meses <- 0
escreval("Salário de Jõao é",sal_jo)
enquanto rend_jo<rend_car faca
rend_car*meses e rend_jo*meses
meses<-meses+1
fimenquanto
se (rend_jo>rend_car) entao
escreval("Para ultrapassar o valor pertencente à Jõao levou:",meses)
escreval("meses")
fimse
se (rend_jo=rend_car) entao
escreval("Para igualar o valor pertencente à Carlos Jõao levou:",meses)
escreval("meses")
fimse
-------------------------------------------------------------------------------
Sintaxe incorreta na linha 20, por favor ajudem aí...
Voltar ao Topo Ir em baixo
Ver perfil do usuário
diegofv
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 31
Localização : rs
Data de inscrição : 25/10/2012

MensagemAssunto: Re: Ajuda para algoritmos basicos   Qui Out 25, 2012 9:24 pm

Se puderem ajudar!

algoritmo para ler 50 itens e ordenar 10 mais onerosos. e criar operaçao de baixa dos intens utilizados no dia.
obrigado
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Ajuda para algoritmos basicos   

Voltar ao Topo Ir em baixo
 
Ajuda para algoritmos basicos
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Ajuda para impedir que o banner ou logo redimensione, preciso travá-lo de acordo com o tamanho do fórum
» Ajuda para criar uma barra de inicio "gostosa"
» Ajuda para editar codigo de chat box personalizado
» Ajuda para colocar o xat
» Ajuda para mudar de dominio personalizado

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: