VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Ajuda plis algoritmo de uma Biblioteca...

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
LuisHMR
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 26
Localização : MG-BH
Data de inscrição : 06/11/2010

MensagemAssunto: Ajuda plis algoritmo de uma Biblioteca...   Sab Nov 06, 2010 6:38 pm

Faça um algoritmo que cadastre até 10.000 livros em uma biblioteca (Nome, Autor, Ano, Editora). Após cadastrar um livro o algoritmo deve ordenar os livros em ordem alfabética, após ordena - los deve aparecer o seguinte menu:

1_Buscar
2_Cadastrar
3_Ver lista

Se o usuário optar por buscar, deve ser pedido para o usuário informar o nome do livro que deseja procurar, caso seja encontrado mostre os dados do livro (Autor, Ano, Editora), se não encontrar a mensagem ''Livro não encontrado''.
Se o usuário optar por cadastrar, deve-se fazer mais um cadastro caso não seja atingido o limite.
Se a opção ''Ver lista'' for escolhida o algoritmo deve mostrar uma lista com os dados de todos os livro cadastrados na biblioteca.

Por favor to precisando muito de uma ajuda ...
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Rogerio
Novato
Novato
avatar

Masculino
Número de Mensagens : 5
Idade : 25
Localização : Açailândia - MA
Data de inscrição : 03/01/2011

MensagemAssunto: Re: Ajuda plis algoritmo de uma Biblioteca...   Dom Jan 09, 2011 1:37 pm

algoritmo "Biblioteca"
// Função :
// Autor :

var

//Criação das variaveis

livro, autor, editora, ano: vetor [1..10] de caracter
x: inteiro
opcao: inteiro

//criacao do menu de opções

procedimento MenuP

var
//não irei utilizar nenhuma var local neste procedimento.
inicio

Limpatela
Escreval (" ******************")
Escreval (" * MENU PRINCIPAL *")
Escreval (" ******************")
Escreval ("")
escreval ("#1 - Cadastrar #2 - Listar #3 - Buscar #4 - Sair")
Escreval ("")
Escreva ("Entre com a sua opção: ")
leia (opcao)
escolha opcao
caso 1
cadastro
caso 2
listar
caso 3
buscar
caso 4
Sair
outrocaso
MenuP
fimescolha

fimprocedimento

// Fim procedimento menu principal


//inicio do menu Cadastro.

procedimento cadastro

var

//não necessita utilizar nenhuma var local.

inicio

limpatela
Escreval ("")
Escreval (" *****************")
escreval (" * Cadastro Nº",x, " *")
Escreval (" *****************")
escreval ("")
escreva ("Nome do livro: ")
leia (livro[x])
escreva ("Nome do autor: ")
leia (autor[x])
escreva ("Editora: ")
leia (editora[x])
escreva ("Entre com o ano do livro: ")
leia (ano[x])
x <- x + 1
MenuP

fimprocedimento
// Fim procedimento Cadastro

// inicio do procedimento Listar
procedimento listar

var

i: inteiro
c: caracter

inicio

limpatela
Escreval (" ****************")
Escreval (" * LISTAR *")
Escreval (" ****************")
para i de 1 ate (x-1) faca
escreval ("Nome do livro : ", livro[i])
escreval ("Nome do autor : ", autor[i])
escreval ("Nome da editora : ", editora[i])
escreval ("Ano de puplicacao : ", ano[i])
escreval ("")
fimpara
escreval ("Pressione *|ENTER|* para continuar")
leia (C)
MenuP// chama o MENU PRINCIPAL

fimprocedimento
// Fim procedimento Listar

// Busca os registros

procedimento buscar

var

i, a : inteiro
busca, c : caracter

inicio

limpatela
Escreval (" ****************")
Escreval (" * BUSCAR *")
Escreval (" ****************")
escreva ("Entre com o nome do livro: ")
leia (busca)
a <- 0
para i de 1 ate (x - 1) faca
se livro[i] = busca entao
a <- i
fimse
fimpara
//inicio de impressão do livro.
se a> 0 entao
Escreval (" ***********************************")
Escreval ("Nome do livro : ", livro[a])
Escreval ("Nome do autor : ", autor[a])
Escreval ("Nome da editora : ", editora[a])
Escreval ("Ano de publicação : ", ano[a])
Escreval (" ***********************************")
Escreval ("")
senao
escreval ("O livro ", busca, " não foi encontrado em nosso banco de dados")
fimse
escreval ("Pressione *|ENTER|* para continuar")
leia (c)
MenuP

fimprocedimento
// Fim procedimento Buscar

//inicio do procedimento SAIR
procedimento sair

inicio
limpatela
fimprocedimento
//fim do procedimento SAIR


inicio
//*********
//atribuir valor para X
x<- 1
//*********


//MENU PRINCIPAL
MenuP

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Ajuda plis algoritmo de uma Biblioteca...
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» ajuda com Pac-man
» Preciso da ajuda na resolução deste exercicios não resolvidos de Algoritmo! Socorro
» Ajuda com ranks
» Me ajuda aqui por favor
» Ajuda com rank

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: