VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Problemas com divisores

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
douglas.estacio
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 37
Localização : Paracambi - RJ
Data de inscrição : 11/11/2010

MensagemAssunto: Problemas com divisores   Qui Nov 25, 2010 12:45 am

fala pessoal, blza?
alguém pode me ajudar ... é q eu fiz um algoritmo q calculasse qtos divisores ele tem. até aí td certo, mas eu qro ver quais são os divisores e não estou conseguindo pôr na tela. por exemplo: d(10) = {1,2,5 e 10}
eis o codigo:

algoritmo " divisores"
var
n, i, cont: inteiro
resp: caracter
inicio
cont := 0
resp := "s"
enquanto resp="s" faca
escreva ("Digite o valor de n: ")
leia (n)
para i de 1 ate n faca
se (n % i = 0) entao
cont := cont + 1
fimse
fimpara
escreval ("O número ", n, " tem", cont, " divisores")
escreva ("Deseja continuar: s/n? ")
leia(resp)
limpatela
fimenquanto
fimalgoritmo


aguardo respostas
abs!!!
afro
Voltar ao Topo Ir em baixo
Ver perfil do usuário
jrlindo10
Novato
Novato
avatar

Masculino
Número de Mensagens : 11
Idade : 25
Localização : Açailandia - MA
Data de inscrição : 22/09/2010

MensagemAssunto: Re: Problemas com divisores   Dom Nov 28, 2010 6:25 pm

inicio
leia (n)
para i de 1 ate n faca
se (N MOD I = 0) entao
Escreval (i)
fimse
fimpara
escreval ("O número ", n, " tem", i, " divisores")
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Problemas com divisores
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Problemas com colorir fundo
» Problemas com cores de títulos em css
» Problemas no ' sub endereço '
» Problemas com visualização de páginas HTML
» Problemas com a pré-visualização

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: