VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Me ajude nesse algoritmo vetor

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Tony Lino
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 29
Localização : MINAS GERAIS
Data de inscrição : 28/11/2010

MensagemAssunto: Me ajude nesse algoritmo vetor    Dom Nov 28, 2010 11:51 am

Criar um algoritmo que preencha um vetor de 15 posições e em seguida receba um valor X qualquer. Seu algoritmo deverá fazer uma busca do valor de X no vetor e informar se o número foi encontrado ou se não foi encontrado, para exibir se o número procurado está no vetor. Se estiver irá apresentar quantas ocorrências. Caso contrário informará que não encontrou o número.
Não estou conseguindo fazer o contador e esta dando erro na linha onde se (NUMERO[i] = num) entao, mas a logica esta certa creio eu, e não estou conseguindo fazer o contador de numeros que eu quero encontrar dentro da matriz.




Algoritmo "vetores"
VAR
NUMERO: VETOR [1..15] de inteiro
I, num, cont: INTEIRO
inicio

cont <- 0
para i de 1 ate 15 faca
escreva("Digite um número: ")
leia (NUMERO[i])
fimpara

para i de 1 ate 15 faca
escreva(NUMERO[i])
fimpara

escreval(" ")
escreva("Digite o número a ser localizado: ")
leia (num)

se (NUMERO[i] = num) entao
escreval ("Foi encontrado ",cont" ocorrencia do numero",num)
senao
escreval("Numero não encontrado")
fimse
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
jrlindo10
Novato
Novato
avatar

Masculino
Número de Mensagens : 11
Idade : 25
Localização : Açailandia - MA
Data de inscrição : 22/09/2010

MensagemAssunto: Re: Me ajude nesse algoritmo vetor    Sex Dez 17, 2010 8:22 pm

Algoritmo "vetores"

var

N: vetor [1..15] de inteiro
I, n2, cont: inteiro

inicio

para i de 1 ate 15 faca
Escreva("Entre com o", i, "º valor: ")
leia (N[i])
fimpara
Escreval ("")
para i de 1 ate 15 faca

Escreva(N[i])
fimpara

Escreval ("")
Escreval ("")
escreva("Entre com o número a ser localizado: ")
leia (n2)

para i de 1 ate 15 faca
se (N[i] = n2) entao
cont<-cont+1]
fimse
fimpara

se(cont>0) entao
Escreval ("")
Escreval("Foi encontrado",cont," ocorrencias do número: ",n2)
senao
Escreval ("")
Escreval("O número", n2, " não foi localizado")
fimse

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Me ajude nesse algoritmo vetor
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Vetor] Retro Stars
» Meu vetor - Desenho
» Alterar o tamanho da fonte nesse código
» Me ajudem nesse código!
» Galera erro no forum, image ajude pf [rapidim]

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: