VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Algoritmo para converter bases numéricas

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Hotwave
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 38
Localização : Santos
Data de inscrição : 06/03/2011

MensagemAssunto: Algoritmo para converter bases numéricas   Ter Mar 08, 2011 12:24 pm

Olá gente,

Sou aluno do primeiro ciclo de ADS, e estou aprendendo o básico ainda. Estou com dificuldade no seguinte exercício:

"Receba um número no sistema decimal e converta para binário. Exiba o binário"

A idéia principal pegar o número e dividí-lo por 2 e ir somando os restos, correto? Mas não sei como continuar dividindo o número digitado pelo usuário para converter para binário

O que eu já fiz:

var

numero, resto : inteiro

inicio

escreval ("digite um número ")
leia (numero)
numero mod 2 // inicio da conversão
resto := numero mod 2 // resto da primeira divisão

se resto<=2 entao // continuar a divisão
???????
?????????

fimalgoritmo



Voltar ao Topo Ir em baixo
Ver perfil do usuário
Virgílio Cossa
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 28
Localização : Maputo-Mocambique
Data de inscrição : 12/05/2014

MensagemAssunto: Re: Algoritmo para converter bases numéricas   Seg Maio 12, 2014 9:32 am

Tenho aqui uma solucão..

algoritmo "Conversão de Bases"
// Função :Converter Bases Numéricas
// Autor : virgilio Cossa
// Data : 9/5/2014
// Seção de Declarações
var
numero, resto : inteiro
X:caracter
inicio
Escreva("Digite o nº Decimal")
leia(numero)
enquanto numero>0  faca
  resto<-(numero) mod 2
  x<-numpcarac(resto)+x     // Converte o resto para caracter e concatena em frente ao "X"
  numero<-(numero) div 2
fimenquanto

  escreval("A conversão resultou em ",X, "Binário")

FimAlgoritimo



Espero ter ajudado...
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Algoritmo para converter bases numéricas
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: