VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Algorítimo similar ao sistema "Grep" do Linux.

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Noobnovato
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 27
Localização : Amapá
Data de inscrição : 06/04/2011

MensagemAssunto: Algorítimo similar ao sistema "Grep" do Linux.   Qua Abr 06, 2011 1:48 pm

Olá a todos. Estou precisando de ajuda para desenvolver um algorítimo que tenha função similar ao sistema "Grep" do linux.

"grep é um aplicativo para linha de comando de sistemas Unix/Linux que faz buscas no conteúdo dos arquivos (ou input) procurando linhas que respeitem a expressão regular mencionada. Todas as linhas encontradas são mostradas na saida padrão (geralmente o monitor)."

Tentei usando o comando "copia" e "compr", mas não obtive o resultado esperado.

Por favor, alguém me ajude.

Se não fui claro o bastante, favor, diga-me. Shocked
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Noobnovato
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 27
Localização : Amapá
Data de inscrição : 06/04/2011

MensagemAssunto: Pra ser mais preciso.   Qua Abr 06, 2011 8:27 pm

O exercício que eu preciso resolver é o seguinte: Algoritmo de Identificação de textos. Elabore um algoritmo semelhante ao GREP do Linux, capaz de localizar um texto dentro de outro texto.

Por favor, estou entrando em desespero. pale
Voltar ao Topo Ir em baixo
Ver perfil do usuário
mudinho
Novato
Novato


Masculino
Número de Mensagens : 3
Idade : 23
Localização : goiania
Data de inscrição : 20/04/2011

MensagemAssunto: Re: Algorítimo similar ao sistema "Grep" do Linux.   Qua Abr 20, 2011 11:53 pm

Cara eu fiz esse :
Código:
algoritmo "Reconhecimento de palavra"
// Função :
// Autor :
// Data : 19/04/2011
// Seção de Declarações
var
frase : literal
palavra : literal
controle, b, c, d, v  : inteiro
lol : vetor [1..20,1..3] de inteiro
procedimento acharpalavra (var x, y : literal)
inicio
c <- 1
v <- 1
para controle de 1 ate compr(y) faca
  se copia(y,controle,1) = copia(x,c,1) entao
      c <- c + 1
  senao
      c <- 1
  fimse
  se c = compr(x) entao
      lol[v,1] <- 1
      lol[v,2] <- ((controle+2)-compr(x))
      lol[v,3] <- controle+1
      v <- v + 1
  fimse
fimpara
fimprocedimento
inicio
// Seção de Comandos
escreval ("Escreva a frase")
leia (frase)
escreval ("escreva a palavra a ser identificada")
leia (palavra)
acharpalavra (palavra,frase)
limpatela
para controle de 1 ate 20 faca
  se lol[controle,1] = 1 entao
      escreval ("")
      Escreval ("A sua ", controle, "º palavra começa na ", lol[controle,2], "º letra e termina na ", lol[controle,3], "º letra")
  fimse
fimpara
fimalgoritmo
usei procedimento pra fica mais facil o acesso,

pra acessa ele e so escreve

acharpalavra(variavel_da_palavra_a_ser_achada,variavel_aonde_o_texto_esta_armazenado)

armazena ate 20 palavras achadas no texto,

a variavel lol, e uma matriz de 20 por 3, aonde a linha(1..20) indica a quantidade de palavras achadas, e a coluna (1..3), na posição(coluna) 1, se o valor for 1, indica q aquela posição da linha esta sendo usada,na posição(coluna) 2, indica em qual letra começa a palavra,na posição(coluna) 3, indica em qual letra termina a palavra.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Algorítimo similar ao sistema "Grep" do Linux.   

Voltar ao Topo Ir em baixo
 
Algorítimo similar ao sistema "Grep" do Linux.
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Engine] MyLife, jogo similar a TheSims
» Sistema de registro e login por lists
» Simples sistema de menu 1.0
» Icones do Linux
» Engine Sistema Solar (terra)

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: