VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Algoritmos

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
febem70
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 24
Localização : VGA
Data de inscrição : 22/04/2011

MensagemAssunto: Algoritmos   Sex Abr 22, 2011 12:01 pm

Meu professor me passou uma lista de algoritmos pra fazer, em Visualg. Só que ele usa comandos que ainda não ensinou para a classe, eu fui pedir pra ele explicar e ele falou pra ir pesquisando, mas nunca acho nada parecido em Visualg. Vou colocar aqui alguns exercícios para me ajudarem:

37. Entrar com o nome e informar se o primeiro caractere é vogal ou consoante.
38. Entrar com dois nomes e imprimi-los em ordem alfabética.
39. Entrar com três números e imprimir o maior deles.
40. Entrar com três números e imprimi-los em ordem crescente.
41. Entrar com três números e imprimi-los em ordem decrescente.
42. Entrar com três números e imprimir uma mensagem dizendo se eles podem ser lados de um triângulo.

Alguém pode me ajudar com a resolução de algum desses algoritmos?
OBS: Algoritmos tem que ser feitos em Visualg 2.0
Obrigado!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
mudinho
Novato
Novato


Masculino
Número de Mensagens : 3
Idade : 23
Localização : goiania
Data de inscrição : 20/04/2011

MensagemAssunto: Re: Algoritmos   Qua Abr 27, 2011 10:38 pm

ate hoje não vi nenhuma diferença entre o 2.0 e o 2.5, tirano o fato q o 2.0 tem q instala e o 2.5 não precisa instala

pra acha os comandos de literal e de numero do visualg entra nesse links : http://www.apoioinformatica.inf.br/visualg/funcoes.htm

e aki esta os comandos de repetição, condição, procedimento e etc, são varias paginas, essa primeira pagina.
http://www.apoioinformatica.inf.br/visualg/linguagem.htm


ja fiz alguns desses algoritmos, não são tão dificeis, basta saber usar o comando de condição, e de repetição, ja o de dexa em ordem crescente ta aqui, vai uma dica pra faze o de exibi os nomes em ordem alfabetica,

a < b < c (o visualg reconhece esse tipo e condição pra letras)



algoritmo "semnome"
// Função :
// Autor :
// Data : 21/3/2011
// Seção de Declarações
var
vet1 : vetor [1..10] de real
controle, controle2 : inteiro
meio : real
inicio
// Seção de Comandos
cronometro on
limpatela
para controle de 1 ate 10 faca
__escreval ("digite o ", controle, "º valor.")
__leia (vet1[controle])
__limpatela
fimpara
para controle de 1 ate 10 faca
__para controle2 de 1 ate 10 faca
____se vet1[controle] < vet1[controle2] entao // mude o sinal de comparação pra mudar pra decrescente
_____meio <- vet1[controle]
_____vet1[controle] <- vet1[controle2]
_____vet1[controle2] <- meio
____fimse
__fimpara
fimpara
para controle de 1 ate 10 faca
__escreval (vet1[controle])
fimpara
cronometro off
fimalgoritmo



estude como o algoritmo funciona, pois não adianta nada so pega ele pronto, pois vc vai usar ele em outras linguagens, e bom vc sabe como funciona a logica dele, ja to passando ele pra não necessita de um vetor pra armazenamento dos numeros, mas sim apenas duas variaveis literais
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Algoritmos
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Av - Logicando: Praticando Algoritmos
» Respostas das oito questões do ENADE algoritmos e programação
» Curso Logicando - Praticando Algoritmos
» Cursos livres - Logicando Praticando Algoritmos
» Oito questões do simulado ENADE, lógica de programação 2014.

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Suporte-
Ir para: