VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Formando Triângulos através de 3 pontos

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
JuF
Novato
Novato


Feminino
Número de Mensagens : 1
Idade : 25
Localização : Brasil
Data de inscrição : 28/04/2011

MensagemAssunto: Formando Triângulos através de 3 pontos   Qui Abr 28, 2011 7:21 pm

Gente, preciso de uma super ajuda....
Preciso resolver o seguinte algoritmo:
Escrever um algoritmo que receba as coordenadas de três ponto no plano e verifique se os três pontos formam um triângulo. Se os pontos formarem um triângulo, o algoritmo deve calcular os três angulos internos e a área desse triângulo. Todas as respostas devem ser exibidas para o usuário.
Para cada conjunto de valores de coordenadas, indicar qual o resultado esperado (triangulo equilatero,isoceles ou escaleno).

Eu já fiz parcialmente,

var
x1,x2,x3,y1,y2,y3:real
P1,P2,P3:vetor [1,2] de real
A,B,C:real
inicio
Escreva ("Digite as coordenadas P1")
Leia (x1,y2)
Escreva ("Digite as coordenadas P2")
Leia (x2,y2)
Escreva ("Digite as coordenadas P3")
Leia (x3,y3)
A <-(x2-x1)^2+(y2-y1)^2
A <- raizQ(A)
escreva ("A=", A)
B <-(x3-x1)^2+(y3-y1)^2
B <- raizQ(B)
escreva ("B=", B)
C <-(x3-x2)^2+(y3-y2)^2
C <- raizQ(C)
escreva ("C=", C)
se(B-C<A) e (A<B+C)ENTAO
se (A=B) e (B=C) e (A=C) entao
escreva ("Triângulo Equlilátero")
senao
se (A<>B) e (B<>C) e (A<>C) entao
escreva ("Triângulo Escaleno")
senao
se (A=B) e (A<>C) entao
escreva ("Triângulo Isóceles")
senao
se (A=C) e (A<>B) entao
escreva ("Triângulo Isóceles")
senao
se (B=C) e (B<>A) entao
escreva ("Triângulo Isóceles")
fimse
fimse
fimse
fimse
fimse
senao
escreva ("Não formam um triângulo")
fimse
fimalgoritmo

Porém eu não to conseguindo sair do lugar, além do mais eu não consigo fazer de jeito nenhum que ele dê como esposta triângulo equilátero, sendo que com as coordenadas (-2,0) (0,-2) (0.732050807568877,0.732050807568877) os lados são iguais.

Por favor, se alguém pudesse me ajudar eu agradeceria muito!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Formando Triângulos através de 3 pontos
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: