VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Problemas com vetor.

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Egon_barth
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 34
Localização : Brasilia
Data de inscrição : 22/05/2011

MensagemAssunto: Problemas com vetor.   Dom Maio 22, 2011 5:15 pm

Bom dia,

estou tendo problemas com um exercicio de vetores,
eu fiz um algoritmo (que esta no outro pc, mas anyway)que é quase a resposta... o problema é, quase
vou procurar postar em seguida. mas a questao é essa:

Uma escola deseja fazer uma análise dos candidatos do vestibular. Para cada curso oferecido, serão entrados os dados: código do curso, número de vagas, número de candidatos do sexo masculino e número de candidatos do sexo feminino
A entrada é finalizada com código zero.
Mostrar para cada curso, uma relação contendo o código do curso, porcentagem de candidatos do sexo masculino, porcentagem de candidatos do sexo feminino
Total de candidatos geral

solução proposta e QUASE certa é essa:

algoritmo "11.5"
// Função : Totalizar candidatos
// Autor : Egon
// Data : 18/5/2011
// Seção de Declarações
var
nome_curso: vetor [1..30] de caracter
Num_vagas, Num_masc, Num_fem, Cod_curso: vetor [1..30] de real
j: inteiro
f: inteiro
inicio
// Seção de Comandos
Escreval ("Cursos")
Escreval ("Numero maximo de cursos a serem incluidos é 30.")
Escreval ("Digite 0 em 'Finalizar' para finalizar a inserção.")
se (f)=0 entao
j<-30
para j de 1 ate 30 faca
Escreva ("Digite o codigo do curso: ")
leia (cod_curso[j])
escreval
Escreva ("Digite o nome do curso: ")
leia (nome_curso[j])
escreval
Escreva ("Digite o numero total de vagas: ")
leia (num_vagas[j])
escreval
Escreva ("Digite o numero de inscriçoes masculinas: ")
leia (num_masc[j])
escreval
Escreva ("Digite o numero de inscriçoes femininas: ")
leia (num_fem[j])
escreval
senao
escreva ("Finaliza: ")
leia (f)
escreval ("Operação finalizada!")

fimse
fimpara
para j de 1 ate 30 faca
Escreva ("Codigo do curso: ", cod_curso[j])
escreval
Escreva ("Nome do curso: ", nome_curso[j])
escreval
Escreva ("Numero total de vagas: ", num_vagas[j])
escreval
Escreva ("Porcentagem de inscriçoes masculinas: ", num_masc[j]*100/num_vagas[j], "%")
escreval
Escreva ("Porcentagem de inscriçoes femininas: ", num_fem[j]*100/num_vagas[j], "%")
escreval
fimpara
fimalgoritmo

Agradeço por antecedencia.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Egon_barth
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 34
Localização : Brasilia
Data de inscrição : 22/05/2011

MensagemAssunto: Re: Problemas com vetor.   Qui Maio 26, 2011 6:50 pm

Ok, tive aula sobre isso ontem, e o algoritmo foi resolvido com um
para j de 1 ate 30 faca
escreval ("finaliza")
leia (f)
se (f)=0 entao
interrompa
fimse
......
serve para quem nao consegue fazer igual.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Problemas com vetor.
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: