VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Exercicios do VisualG

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
PhantomBr
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 21
Localização : aqui
Data de inscrição : 29/05/2011

MensagemAssunto: Exercicios do VisualG   Dom Maio 29, 2011 10:41 pm

Olá glr, eu estou cursando manutenção e suporte a informática, porém tenho uma matéria chata de logica de programação que envolve visualg e a profª passou uma atividade com mts exercicios bem chatos e eu n consigo resolver sem ajuda.
aqueles que tiverem paciencia em me ajudar eu serei muito grato.
aqui vai a lista de exercicios:

Envolvendo o Comando REPITA

1) Escrever um algoritmo que lê 5 valores para a, um de cada vez, e conta quantos destes valores são negativos, escrevendo esta informação

2) Escrever um algoritmo que lê um valor N inteiro e positivo e que calcula e escreve o valor de E
E = 1 + 1 / 1! + 1 / 2! + 1 / 3! + 1 / N!

3) A prefeitura de uma cidade fez uma pesquisa entre seus habitantes, coletando dados sobre o salário e o número de filhos. A prefeitura deseja saber:
a) média do salário da população
b) média do número de filhos
c) maior salário
d) percentual de pessoas com salário ate R$100,00

O final da leitura de dados se dará com a entrada de um salário negativo. (Use o comando ENQUANTO-FAÇA)

4) Chico tem 1,50 metro e cresce 2 centímetros por ano, enquanto Zé tem 1,10 metro e cresce 3 centimetros por ano. Construa um algoritmo que calcule e imprima quantos anos serão necessários para que Zé seja maior que Chico.

5) Construir um algorítmo que calcule a média aritmética de vários valores inteiros positivos, lidos externamente. O final da leitura acontecerá quando for lido um valor negativo.

6) Em uma eleição presidencial existem quatro candidatos. Os votos são informados através de códigos. Os dados utilizados para a contagem dos votos obedecem à seguinte codificação:
-1,2,3,4 = voto para os respectivos candidatos;
-5 = voto nulo;
-6 = voto em branco;

Elabore um algoritmo que leia o código do candidato em um voto. Calcule e escreva:

-total de votos para cada candidato;
-total de votos nulos;
-total de votos em branco;

Como finalizador do conjunto de votos, tem-se o valor 0


-----
Ta ai glr, essa é a lista de exercicios bem chatos que não consigo fazer hehe.. (lembrando que copiei da folha) e devo usar os comandos REPITA, ATE, ENQUANTO e FAÇA. Gostaria muito da ajuda de voceis pois isso vale minha nota ^^
obrigado ae!!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
poet
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 27
Localização : VAI ME SEQUESTRAR??
Data de inscrição : 27/05/2012

MensagemAssunto: Re: Exercicios do VisualG   Seg Maio 28, 2012 6:43 pm

Citação :
algoritmo "semnome"
// Função :
// Autor :
// Data : 27/04/2012
// Seção de Declarações
var
votos,t1,t2,t3,t4, nulo, branco : inteiro
inicio
repita
Escreval (" <><><><>Escolha o seu Candidato<><><><>")
Escreval ("Digite 1º para votar no Candidato Numero 1")
Escreval ("Digite 2º para votar no Candidato Numero 2")
Escreval ("Digite 3º para votar no Candidato Numero 3")
Escreval ("Digite 4º para votar no Candidato Numero 4")
Escreval ("Digite 5º para votar em nulo")
Escreval ("Digite 6º para votar em branco")
Leia (votos)
Escolha votos
caso 1
t1 := t1 + 1
caso 2
t2 := t2 + 1
caso 3
t3 := t3 + 1
caso 4
t4 := t4 + 1
Caso 5
nulo := nulo + 1
caso 6
branco := branco + 1
fimescolha
limpatela
ate votos = 0

escreval ("Candidato 1 obteve ", t1," votos.")
escreval ("Candidato 2 obteve ", t2," votos.")
escreval ("Candidato 3 obteve ", t3," votos.")
escreval ("Candidato 4 obteve ", t4," votos.")
escreval ("--------")
escreval ("O total de votos nulos foi: ", nulo)
escreval ("O total de votos em branco foi: ", branco)

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
leandro_
Novato
Novato


Masculino
Número de Mensagens : 7
Idade : 28
Localização : Curitiba
Data de inscrição : 14/12/2012

MensagemAssunto: Re: Exercicios do VisualG   Sex Dez 14, 2012 6:16 pm

OLá PhantomBr,

O primeiro exercicio:

algoritmo "semnome"
// Função :
// Autor :
// Data : 14/12/2012
// Seção de Declarações
var
aux,negativo,a:inteiro
inicio

repita
escreva("Valor",aux+1,":")
leia(a)
se a<0 entao
negativo<-negativo+1
fimse
aux<-aux+1
ate aux=5
fimrepita
escreva("valores negativos:",negativo)

// Seção de Comandos
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
leandro_
Novato
Novato


Masculino
Número de Mensagens : 7
Idade : 28
Localização : Curitiba
Data de inscrição : 14/12/2012

MensagemAssunto: Re: Exercicios do VisualG   Sab Dez 15, 2012 1:50 pm

Exercicio 2:

algoritmo "semnome"
// Função : Resultado e E
// Autor : leandro
// Data : 14/12/2012
// Seção de Declarações
var
dividendo,divisor:real
n:inteiro
inicio
dividendo<-1
divisor<-1
escreva("Numero:")
leia(n)
enquanto divisor<=n faca
dividendo<-dividendo+1/divisor
dividendo<-dividendo+1
divisor<-divisor+1
fimenquanto
escreva("E =",dividendo)
// Seção de Comandos
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
leandro_
Novato
Novato


Masculino
Número de Mensagens : 7
Idade : 28
Localização : Curitiba
Data de inscrição : 14/12/2012

MensagemAssunto: Re: Exercicios do VisualG   Sab Dez 15, 2012 9:12 pm

Exercicio 3:

algoritmo "Coletando Dados"
// Função :
// Autor : leandro
// Data : 15/12/2012
// Seção de Declarações
var
num_filhos:vetor[0..4] de inteiro
salario: vetor[0..4] de real
media_salario: real
media_num_filhos: real
maior_salario: real
porcent_cem: real
aux,registro: inteiro
inicio

repita
limpatela
registro<-registro+1
escreval("__________________________________________________")
escreval(" SENSO FAMILIAS ")
escreval("__________________________________________________")
escreval()
escreval(" REGISTRO: ",registro)
escreva("Numero de Filhos: ")
leia(num_filhos[aux])
escreva("Salario: ")
leia(salario[aux])
media_salario<-media_salario+salario[aux]
media_num_filhos<-media_num_filhos+num_filhos[aux]
se maior_salario<salario[aux] entao
maior_salario<-salario[aux]
se salario[aux]<=100 entao
porcent_cem<-porcent_cem+1
fimse
fimse
escreval()
escreva("<1> Continuar / <0> Sair: ")
leia(aux)
ate aux=0
fimrepita
media_salario<-media_salario/registro
media_num_filhos<-media_num_filhos/registro
limpatela
escreval("A média do Salário : ",media_salario)
escreval("A Média do Número de Filhos : ",media_num_filhos)
escreval("Maior Salário : ",maior_salario:2:2)
escreval("Porcentual de Pessoas que ganham até 100,00:
",porcent_cem*100/registro:2:2,"%")
// Seção de Comandos
fimalgoritmo

Obs: Não tenho certeza se o porcentual de pessoas que ganham até 100 está correto ok.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
leandro_
Novato
Novato


Masculino
Número de Mensagens : 7
Idade : 28
Localização : Curitiba
Data de inscrição : 14/12/2012

MensagemAssunto: Re: Exercicios do VisualG   Sab Dez 15, 2012 9:39 pm

Exercicio 4:

// Autor : leandro
// Data : 15/12/2012
// Seção de Declarações
var
anos:real
inicio

anos<-(150-110)+1
escreval(anos,"serão necessarios para que Zé seja maior que Chico")
// Seção de Comandos
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
leandro_
Novato
Novato


Masculino
Número de Mensagens : 7
Idade : 28
Localização : Curitiba
Data de inscrição : 14/12/2012

MensagemAssunto: Re: Exercicios do VisualG   Dom Dez 16, 2012 11:47 am

Exercicio 5:

algoritmo "Média aritmetica"
// Função : "Média aritmetica"
// Autor : leandro
// Data : 16/12/2012
// Seção de Declarações
var
media: real
valor: inteiro
aux : inteiro
inicio
repita
aux<-aux+1
escreva("Valor: ")
leia(valor)
media<-media+valor
ate valor=-1
escreval()
escreva("A média aritmetica é: ",media/aux)
fimrepita
// Seção de Comandos
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
leandro_
Novato
Novato


Masculino
Número de Mensagens : 7
Idade : 28
Localização : Curitiba
Data de inscrição : 14/12/2012

MensagemAssunto: Re: Exercicios do VisualG   Dom Dez 16, 2012 2:31 pm

Exercicio 6:

algoritmo "separando votos"
// Função :"separando votos"
// Autor : leandro
// Data : 16/12/2012
// Seção de Declarações
var
aux,voto,branco,nulo:inteiro
cand_1,cand_2,cand_3,cand_4:inteiro
inicio
aux<-1
enquanto aux<>0 faca
limpatela
escreva("Codigo do candidato: ")
leia(voto)
escolha voto
caso 1
cand_1<-cand_1+1
caso 2
cand_2<-cand_2+1
caso 3
cand_3<-cand_3+1
caso 4
cand_4<-cand_4+1
caso 5
nulo<-nulo+1
caso 6
branco<-branco+1
outrocaso
escreva("OPÇÃO INEXISTENTE - <1> p/ continuar. <0> p/ Sair:")
leia(aux)
fimescolha
fimenquanto
limpatela
escreval("Candidato 1 recebeu: ",cand_1)
escreval("Candidato 2 recebeu: ",cand_2)
escreval("Candidato 3 recebeu: ",cand_3)
escreval("Candidato 4 recebeu: ",cand_4)
escreval("Votos Nulos: ",nulo)
escreval("Votos brancos: ",branco)

// Seção de Comandos
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Exercicios do VisualG   

Voltar ao Topo Ir em baixo
 
Exercicios do VisualG
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Jogo da velha
» Expressões matemáticas, funções e operadores
» #DGM Aula 03 - Sprites
» Poblema com codigo da pagina html
» Aplicar css/html nas mensagens

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: