VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Duvidas: fatorial

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Duvidas: fatorial   Ter Out 30, 2007 11:28 am

Este eu ñ consegui

1 - Escrever um algoritmo/programa que lê um número e calcula e escreve quantos divisores ele possui

Já este eu comecei a fazer

2 - Escreva um algoritmo/programa que leia a idade de 20 pessoas, escrevendo a menor idade e a quantidade de pessoas que possuem essa idade (a menor).

algoritmo "menor idade"
// Função : Calcular a menor idade de um grupo de 20 pessos e mostrar
//quatas pessoas tem idade menor
// Autor : Gustavo Rodrigues Torre
// Data : 11/10/2007
// Seção de Declarações
var
c : inteiro
a,menor, maior, m : real
inicio
// Seção de Comandos
menor <- 3
para c de 1 ate 20 passo 1 faca
escreva ("Entre com a sua idade: ")
leia(a)

se (a < menor) entao
menor <- a
fimse
se (a > maior) entao
maior <- a
fimse

fimpara

escreval

escreval(" A quantidade de pessoas com idade menor e = ",a, " A menor idade eh ",menor)

fimalgoritmo

Este também eu comecei a fazer

3 - Fazer um algoritmo/programa que receba um número inteiro positivo N do usuário e mostre o valor do seu fatorial. Se o usuário não digitar um número inteiro positivo deve ser mostrada uma mensagem de erro e pedir para que ele digite novamente.

algoritmo "fatorial"
// Função : Cálculo do fatorial de um número dados
// Autor : Gustavo Rodrigues Torre
// Data : 13/3/2005
// Seção de Declarações
var
fat, c, N, b : inteiro
//fat: fatorial
//c : contador
//n: numero a ser calculado o fatorial
//b: usado para usar mais uma opção
inicio
b <- 1
enquanto (b=1) faca
limpatela
escreva ("Entre com o número:")
leia(N)

se (n<1) entao
escreval("Tente de novo")
fimse
interrompa
leia(c)

fat <- 1

para c de 1 ate n passo 1 faca
fat <- fat*c
fimpara



escreval("O fatorial de ",N, " é ",fat)
escreval("Deseja continuar? (1)Sim (0)Não")
leia(b)
fimenquanto

fimalgoritmo

Este eu comecei mais não sei onde esta o erro.
E ñ sei se já resolveram para mim.

4 - O número 3025 possui a seguinte característica:

30 + 25 = 55 e 55*55 = 3025.

Fazer um algoritmo/programa para obter todos os números de 4 algarismos com a mesma característica do número 3025.

algoritmo "semnome"
// Função :
// Autor :
// Data : 26/10/2007
// Seção de Declarações
var
n,c : inteiro
j,x,q : real
inicio
// Seção de Comandos
c <- 0
leia(n)
para c de 1 ate n passo 4 faca

j <- (n div 100)
x <-(n %100)
q <- (x + j) ^ 2
q <- q ^ 2
fimpara
escreval(j)
escreval(x)
escreval(q)

fimalgoritmo

Este eu comecei a fazer mais esta dando erro no fatorial

5 - Ler uma matriz A do tipo vetor com 15 elementos. Construir uma matriz B de mesmo tipo e dimensão, sendo que cada elemento da matriz B seja o fatorial do elemento correspondente da matriz A. Apresentar os elementos da matriz B ordenados de forma crescente.

algoritmo "vetor fatorial"
// Função :
// Autor : Gustavo Rodrigues Torre
// Data : 25/10/2007
// Seção de Declarações
var
A,B : vetor[1..15] de real
i: inteiro
inicio
// Seção de Comandos

para i de 1 ate 15 passo 1 faca
escreva("Digite um valor do A", i,":")
leia(A[i])
B[i] <- (A[i]) * i
fimpara
escreval
escreval("Vetor A) Vetor B")

para i de 1 ate 15 passo 1 faca
escreval(" ",A[i]," ",B[i])
fimpara

fimalgoritmo

P.s Se eu tiver mais dúdas eu posto aqui
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Duvidas: fatorial   Ter Out 30, 2007 12:05 pm

Mais atenção as regras

Admin escreveu:

Nona Regra:

Seja objetivo com o título do tópico, nunca use um título dessa forma:
"Duvida."
Seja mais exato:
"Duvida função se."
Ajudará a quem usar a ferramenta de busca.

Nova regra adicionada

Admin escreveu:


Segunda Regra

Peça apenas um algoritmo por post. O nome do post deve identificar o algoritmo.
Esse tópico será respondido normalmente, nome do tópico editado.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Duvidas: fatorial   Ter Out 30, 2007 12:22 pm

1 - Escrever um algoritmo/programa que lê um número e calcula e escreve quantos divisores ele possui.

Você precisará de uma variável acumuladora que receba +1 a cada divisor do número para saber quantos divisores são. Seu algoritmo deve ter uma estrutura assim:

-Um 'para' que começa do número digitado indo até 0 (usar passo -1)
-Um 'se' que verifica o resto da divisão do número por ele mesmo (usar operador %)
-Caso o resto da divisão for 0, então a variável acumuladora terá seu valor aumentado em 1

2- Apague esse trecho junto com a variável 'maior' e 'm', afinal, você só precisa saber o menor número e não o maior, e a variável 'm' não foi utilizada:

se (a > maior) entao
maior <- a
fimse
//isso deve ser apagado

Agora observe o trecho:

se (a < menor) entao
menor <- a
fimse

Isso está correto, só precisa de um ajuste para que mostre quantas idades menores iguais existem. Desse modo:

se (a < menor) entao
menor <- a
senão
se (a = menor) entao
iguais <- iguais + 1
fimse
fimse

3- Os erros desse algoritmo são os seguintes:

se (n<1) entao
escreval("Tente de novo")
fimse
interrompa
leia(c)

Para que você peça o número novamente sempre quando for menor que zero, deve usar 'enquanto' desse modo:

enquanto (n<1) entao
escreval("Tente de novo")
leia (n)
fimenquanto

As linhas de algoritmo : 'leia (c)' e 'interrompa' devem ser simplesmente apagadas

4- Esse algoritmo já havia sido resolvido e enviado ao seu email

5- Basta utilizar o que você fez no algoritmo 3 com certas modificações. Se você tem dúvida sobre ordenação, poste isso (em outro tópico com título explicativo).
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Duvidas: fatorial   Qua Out 31, 2007 9:23 am

Duvida 1 - Eu já fiz mais preciso saber se esta certo

algoritmo "divisores"
// Função : Calcular divisores de um numero
// Autor : Gustavo Rodrigues Torre
// Data : 29/10/07
// Seção de Declarações
var
n,c : inteiro
acm : inteiro
inicio
// Seção de Comandos
acm <-1
escreva("Digite um numero qualquer: ")
leia(n)
para c de n ate 0 passo -1 faca

se (n%n=0) entao
acm <- acm + 1
senao
escreva("Divisão por zero")
fimse
fimpara

escreval("Divisores de",n," =",acm)

fimalgoritmo

2 - OK. Muito obrigado pela ajuda
3 - OK. Muito obrigado pela ajuda
5 - Postado em outro tópico com o nome ordenação de vetores
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Duvidas: fatorial   Qua Out 31, 2007 10:47 am

Resolvido. Tópico Trancado.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
Conteúdo patrocinado




MensagemAssunto: Re: Duvidas: fatorial   

Voltar ao Topo Ir em baixo
 
Duvidas: fatorial
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Duvidas nas mensagens da categoria
» Modulos de duvidas e de criaçoes graficas
» [Resolvido] Duvidas. barra de informações e outra
» Duvidas sobra um Aviso da Fórumeiros
» Como colocar o negocio de duvidas pendentes

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: