VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 não to conseguindo fazer este algoritmos alguem me ajude

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
claudineibotelho
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 40
Localização : Santana da Vargem
Data de inscrição : 21/07/2011

MensagemAssunto: não to conseguindo fazer este algoritmos alguem me ajude   Seg Jul 25, 2011 2:51 pm

Desenvolva um algoritmo que , determine se um determinado número n informado é primo ou não.Se sim , que encontre e informe os dois primos antecessores de n e os dois primos sucessores de n.Armazene estes 5 números (o lido,seus dois antecessores e seus dois sucessores) em um vetor p[5]. O algoritmo só encerra quando for informado um número n primo.

consegui fazer este algoritmo abaixo ele informa se é primo ou não mais não, seu colocar no vetor de 5 posições os dois antecessores e os dois sucessores de n

algoritmo "semnome"
// Função :
// Autor :
// Data : 24/07/2011
// Seção de Declarações
var
num,cont,ndiv:inteiro
inicio
// Seção de Comandos
num<-0
div<-0
cont<-1
escreva("digite um numero:")
leia(num)
repita
se (num%cont)=0 entao
ndiv<-ndiv+1
fimse
cont<-cont+1
ate (cont>num)
se (ndiv=2) entao
escreva("número primo:")
senao
escreva("número não é primo:")
fimse
fimalgoritmo

----------------------------------------------------------------------------
esse outro ta dando erro na variavel



var
p: vetor[1..5] de inteiro
num, i, j: inteiro
continua: logico

funcao ehprimo (int n): logico
var
i: inteiro
eh: logico
inicio
eh <- verdadeiro
para i de 2 ate (n-1) faca
se (n % i = 0) entao
eh <- falso
fimse
fimpara
retorne (eh)
fimfuncao

inicio
para i de 1 ate 5 faca
p[i] <- 0
fimpara
continua <- verdadeiro
repita
leia (num)
se (ehprimo(num)) entao
continua <- falso
p[3] <- num
j <- 2
i <- num - 1
enquanto (j > 0 E i > 0) faca
se (ehprimo(i)) entao
p[j] <- i
j <- j - 1
fimse
i < - i - 1
fimenquanto
j <- 4
i <- num + 1
enquanto (j < 6) faca
se (ehprimo(i)) entao
p[j] <- i
j <- j + 1
fimse
i < - i + 1
fimenquanto
fimse
ate (continua)
para i de 1 ate 5 faca
escreva (" ", p[i])
fimpara
fimalgoritmo

conto com ajuda de você to começando a estudar o algoritmos

















Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
não to conseguindo fazer este algoritmos alguem me ajude
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: