VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Estou com dificuldades.

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Mthz
Novato
Novato


Masculino
Número de Mensagens : 3
Idade : 27
Localização : Frutal
Data de inscrição : 01/08/2011

MensagemAssunto: Estou com dificuldades.   Qua Ago 03, 2011 9:49 pm

Estou com dificuldades no seguinte exercício:
Faça um algoritmo que calcule e escreva o valor a ser pago a sua provedora de acesso à Internet, para isso você deverá ler a quantidade de horas que utilizou. Sabe-se que você pagará R$ 30,00 por até 20 horas de uso (valor básico), caso você tenha usado mais de 20 horas, então você deve acrescentar 10% do valor básico para cada hora extra utilizada.


obrigado Smile
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Lelos
Novato
Novato
avatar

Masculino
Número de Mensagens : 1
Idade : 41
Localização : HELLcife - PE
Data de inscrição : 10/08/2011

MensagemAssunto: Re: Estou com dificuldades.   Qua Ago 10, 2011 2:46 pm

Boa tarde chefe, acabei de me cadastrar e ao FINALMENTE encontrar uma pergunta a qual eu consegui responder, não tive dúvidas e resolvi postar a solução que eu encontrei:

algoritmo "valorpagoprovedor"
// Função : Calcular o valor pago ao provedor
// Autor : Marcelo José Luna Santos
// Data : 10/08/11
// Seção de Declarações
var
n1, V_basico, H_extra, calc_H_extra: real
inicio
escreval("Informe numero de horas utilizadas: ")
leia(n1)
V_basico:=20
H_extra:=(n1-v_basico)
calc_H_extra:=((h_extra*3)+30)
Se n1<=20 entao
escreval("o valor pago será 30,00 reais.")
fimse
se n1>20 entao
escreval("o valor pago será: ",calc_H_extra)
fimse
fimalgoritmo

Para a pergunta feita, sem floreios nem deslizes, acredito eu que esteja correto de acordo com o que se pede.

Espero ter ajudado Very Happy
Acabei de começar a cursar ADS na UNIBRATEC aqui em Recife - PE e, estou adorando! Smile
[]s Lelos.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Mthz
Novato
Novato


Masculino
Número de Mensagens : 3
Idade : 27
Localização : Frutal
Data de inscrição : 01/08/2011

MensagemAssunto: Re: Estou com dificuldades.   Qui Ago 11, 2011 6:14 pm

Vlw ai =D
Abrass
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Estou com dificuldades.   

Voltar ao Topo Ir em baixo
 
Estou com dificuldades.
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Estou com dificuldades com o papel de parede
» estou na parada!
» Não estou conseguindo acessar o fórum com www
» Como descubro o tema que eu estou usando no meu forum ?
» 2 Codigos Faceis que estou precisando ( categoria )

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: