VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Algoritmo de um Banco

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Elton Bruno
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 35
Localização : Governador Valadares
Data de inscrição : 26/08/2011

MensagemAssunto: Algoritmo de um Banco   Qua Set 07, 2011 12:10 pm

Salve, salve amigos(a)
Desejo o entendimento de alguns de vocês!
Fazer um algoritmo com as regras a seguir:

A) Será apresentado na tela assim:

BANCO
SEU SALDO ATUAL É DE 500,00
1-SAQUE
2-DEPOSITO
3-TRANSFERÊNCIA
4-IMPRIMIR EXTRATO
9-SAIR

B) Só sairá do sistema quando for digitado a opção 9.

C) Caso o usuário escolher o SAQUE o sistema deverá exibir uma mensagem pra ele digitar o valor que vai sacar. Logo deverá saber se o valor que o cliente quer sacar é possível baseado no saldo que ele tem disponível na conta, lembre que se o valor do saque for maior do que o saldo disponível, o saque não pode ser realizado, informar isso ao usuário, caso for possível o saque realize-o e atualize o saldo da conta corrente.

D) Caso escolha DEPÓSITO, o sistema vai exibir uma mensagem informando que ele deve digitar o valor do DEPÓSITO. Caso o usuário digite um valor maior que 0, o sistema vai atualizar o SALDO do BANCO somando ao SALDO que existe o valor do DEPÓSITO. Se for digitado um valor menor ou igual a zero o sistema tem que informar que esse valor não é valido.

E) Caso escolha a opção TRANFERÊNCIA, o sistema deve exibir uma mensagem informando que ele deve digitar o valor que quer transferir. Logo se deve saber se o valor a ser transferido é possível baseado no saldo que ele tem disponível em sua conta, lembrando que, se o valor da TRANSFERÊNCIA for maior do que o saldo disponível, não poderá ser realizada e será informado isso ao usuário. Caso seja possível fazer a TRANSFERÊNCIA a mesma deve atualizar o saldo da conta corrente.

F) Caso escolha a opção IMPRIMIR EXTRATO, emita um extrato com todas as operações bem sucedidas das operações bancárias. Para isso, crie um vetor que armazene 100 mensagens, por exemplo, e para cada operação que for bem sucedida, grave a mensagem correspondente nesse vetor informando a operação realizada.
Conforme o exemplo abaixo:

*SALDO INICIAL DE R$ 500,00
*SAQUE DE R$ 100,00 - SALDO RESTANTE DE R$ 400,00
*DEPÓSITO DE R$ 1000,00 - SALDO RESTANTE DE R$ 1.400,00
*SAQUE DE R$ 200,00 - SALDO RESTANTE DE 1.200,00
*TRANSFERÊNCIA DE R$ 1.000,00 - SALDO RESTANTE DE R$ 1.000,00

Esse extrato deve ser questionado quantas copias são desejadas para ser impresso, conforme o número de cópias emita o extrato.

G) Caso queira SAIR, o sistema irá terminar.

obs: Caros e estimados amigos um feliz dia da Independência a todos, "Sempre existe uma saída para qualquer problema, por mais complexo e difícil que nos pareça"...FIQUEM TODOS COM DEUS, A SABEDORIA ALÉM DO QUE IMAGINAMOS...ABÇS!!!!!!!!


Voltar ao Topo Ir em baixo
Ver perfil do usuário
Elton Bruno
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 35
Localização : Governador Valadares
Data de inscrição : 26/08/2011

MensagemAssunto: Re: Algoritmo de um Banco   Seg Nov 14, 2011 4:40 pm

algoritmo "BANCO UNIVALE"

// Autor :E170N 39UNO - ALUNO ETEIT(GV)


var
saldo, valor: real
op,parada: caracter
ext1: vetor [1..100] de caracter
ext2, ext3: vetor [1..100] de real
i,j: inteiro

inicio


j <- 1
saldo <- 500

// Gravar mensagem de extrato
ext1[j] <- "Saldo inicial de "
ext2[j] <- saldo
ext3[j] <- saldo
j <- j + 1
// Final

repita
limpatela
escreval("BANCO UNIVALE")
escreval //esse escreval é para soltar uma linha
escreval("SEU SALDO ATUAL É DE: ", saldo)
escreval
escreval(" 1 - Saque")
escreval(" 2 - Deposito")
escreval(" 3 - Transferencia")
escreval(" 4 - Imprimir Extrato")
escreval(" 9 - SAIR")
escreval ("POR FAVOR DIGITE UMA DAS OPÇÕES!")
leia(op)

escolha op
caso "1"
escreval("DIGITE O VALOR DO SAQUE ")
leia(valor)
se valor > saldo entao
escreval("SAQUE IMPOSSÍVEL POR FALTA DE SALDO; ")
escreva ("APERTE ENTER PARA NOVA OPÇÃO!")
senao
saldo <- saldo - valor

// Gravar mensagem de extrato
ext1[j] <- "Saque de "
ext2[j] <- valor
ext3[j] <- saldo
j <- j + 1
// Final
escreva ("SAQUE REALIZADO, APERTE ENTER PARA NOVA OPÇÃO!")

fimse
leia(parada)

caso "2"
escreval("DIGITE O VALOR DO DEPÓSITO ")
leia(valor)
se valor <= 0 entao
escreval(" DEPÓSITO IMPOSSÍVEL")
escreva ("APERTE ENTER PARA NOVA OPÇÃO!")
senao
saldo <- saldo + valor

// Gravar mensagem de extrato
ext1[j] <- "Deposito de "
ext2[j] <- valor
ext3[j] <- saldo
j <- j + 1
// Final
escreval ("DEPÓSITO REALIZADO, APERTE ENTER PARA NOVA OPÇÃO!")

fimse
leia(parada)


caso "3"
escreval("DIGITE O VALOR DA TRANSFERÊNCIA")
leia(valor)
se valor > saldo entao
escreval("SAQUE IMPOSSÍVEL POR FALTA DE SALDO")
escreva ("APERTE ENTER PARA NOVA OPÇÃO!")
senao
saldo <- saldo - valor
// Gravar mensagem de extrato
ext1[j] <- "Transferencia de "
ext2[j] <- valor
ext3[j] <- saldo
j <- j + 1
// Final
escreva ("TRANSFERÊNCIA REALIZADA, APERTE ENTER PARA NOVA OPÇÃO!")
fimse
leia(parada)

caso "4"
para i de 1 ate 100 faca
se ext1[i] <> "" entao
escreva(ext1[i])
escreva(" ")
escreva(ext2[i])
escreva(" SALDO de.: ")
escreval(ext3[i])

fimse
fimpara
escreva ("APERTE ENTER PARA NOVA OPÇÃO")
leia(parada)

fimescolha

ate op="9"

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Algoritmo de um Banco
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Preciso da ajuda na resolução deste exercicios não resolvidos de Algoritmo! Socorro
» ajuda com Pac-man
» Av - Logicando: Praticando Algoritmos
» [IDEIA] Sistema de save através de algoritmo...?
» ME AJUDEM POR FAVOR, NÃO TO COMPREENDENDO ESSE ALGORITMO

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: