VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 ME AJUDEM PF..........

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Adamos
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 30
Localização : Manaus,Am-BR
Data de inscrição : 15/09/2011

MensagemAssunto: ME AJUDEM PF..........   Qui Set 15, 2011 5:12 pm

tou tendo problema......com esse algoritmo com essa questao.
1)Uma determinada empresa do polo de manaus ira dar um aumento de salario aos seus funcionarios, a equipe de desenvolvimento de solftware tera que elaborar um algoritmo para gerar os valores que irao ser acrescentados aos salarios, o criterio sera:
a)quem ganha ate 400 tera um aumento de 67,6%;
b)acima de 400 ate 1.399.99 tera um aumento de 40%;
c)acima de 1.399.99 o aumento sera 10%;

............Fiz assim + nao ta dando certo ........................
#include<conio.h>
#include<stdio.h>
#include <string.h>
#include<stdlib.h>
#include<iostream>
using namespace std;
main(){

float sal,aum_a,aum_b,aum_c;

cout<<"digite o salario:\n";
cin>>sal;
if (sal=400){
aum_a =(sal*67,6)/100+ sal;
}
else if ((sal >400) && (sal=1400))
aum_b =(sal*40)/100+ sal;
{

if (sal >1400){
aum_c =(sal*10)/100+ sal;
}
cout << "\n O aumento do salario e;\n "<<aum_a;
cout << "\n O aumento do salario e;\n "<<aum_b;
cout << "\n O aumento do salario e;\n "<<aum_c;
}
getch();
}

pode me ajudar.....[b]
Voltar ao Topo Ir em baixo
Ver perfil do usuário
CiD
Novato
Novato
avatar

Masculino
Número de Mensagens : 3
Idade : 31
Localização : Recife - PE
Data de inscrição : 20/08/2011

MensagemAssunto: Re: ME AJUDEM PF..........   Qua Out 05, 2011 9:01 am

Cara, no VisualG fica assim:

var
SAL, NSAL,R :Real
inicio
Escreva("Salário: ")
Leia(SAL)
Se SAL < 400 Entao
R:=SAL*0.676
seNao
Se SAL < 1399.99 Entao
R:=SAL*0.4
seNao
R:=SAL*0.1
fimSe
fimSe
NSAL:=R+SAL
Escreval("Reajuste: ",R)
Escreval("Novo Salário: ",NSAL)
fimalgoritmo

Uma forma de fazer claro, ai voce passa pra sua linguagem usando essa mesma logica ae. Sou novo por aqui nao sei se tw ajudando ou atrapalhando mais ainda, mas ta ae xD
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
ME AJUDEM PF..........
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Me Ajudem com Radio...
» Ajudem e fazer um menu asim ?
» Me ajudem nesse código!
» Menu desalinhado ajudem-me
» Por favor min ajudem e importante pra min

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: