VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Algoritmo de vetor

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Flavia
Novato
Novato


Feminino
Número de Mensagens : 1
Idade : 26
Localização : Curitiba - PR
Data de inscrição : 24/10/2011

MensagemAssunto: Algoritmo de vetor   Seg Out 24, 2011 2:41 pm

Olá, meu nome é Flávia e estou tendo dificuldades pra fazer esse programa:
1) escreva um programa que leia 10 num pelo teclado, e coloque cada um dos valores em um vetor de 10 ints

a)leia os valores para guardar no vetor
b)mostre o conteudo do vetor em uma linha
c)mostre o conteudo do vetor em ordem do último para o primeiro
d) mostre só os elementos pares
e)mostre os elementos maiores que 10
f) mostre o maior e o menor valor lido do vetor
g) calcule a média dos valores no vetor
h) mostre somente os valores acima de média.

Muito obrigada a quem responder Very Happy
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Diego
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 20
Localização : Maranhão
Data de inscrição : 17/11/2011

MensagemAssunto: Re: Algoritmo de vetor   Sab Nov 26, 2011 9:14 am

Flávia meu nome é Diego eu fiz um algoritimo, só q não tem tds as opções, tomara q ti ajude




algoritmo "vetor"
var
a:vetor[1..10]de inteiro
opcao:caractere
soma,cont:inteiro

inicio
repita
Escreval ("1-insirir valores no vetor:")
Escreval ("2-mostre o conteudo do vetor em uma linha")
Escreval ("3-mostre os elementos maiores que 10")
Escreval ("4-calcule a média dos valores no vetor")
Escreval ("0-SAIR")
Escreval ("escolha uma oção:")
leia(opcao)
limpatela
escolha opcao

caso "1"

para cont de 1 ate 10 faca
Escreval ("digite os numeros:")
leia (a[cont])
fimpara

caso "2"

para cont de 1 ate 10 faca
Escreval (a[cont])
fimpara

caso "3"

para cont de 1 ate 10 faca
se (a[cont] >10) entao
escreval(a[cont])
fimse
fimpara

caso "4"
para cont de 1 ate 10 faca
soma <- soma+a[cont]
fimpara
Escreval ("a emdia é",soma/10)
fimescolha
ate opcao="0"
fimrepita
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Algoritmo de vetor
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Vetor] Retro Stars
» Meu vetor - Desenho
» [Vetor] Desenhando e Vetorizando, [Video] Mickey Mouse
» Preciso da ajuda na resolução deste exercicios não resolvidos de Algoritmo! Socorro
» Visual G - Vetor decrescente

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: