VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Ajuda, com cadastro e pesagens

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Lost
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 27
Localização : Brasil
Data de inscrição : 12/11/2011

MensagemAssunto: Ajuda, com cadastro e pesagens   Sab Nov 12, 2011 6:08 pm

A lógica olhar esta coerente mas eu não consigo rodar, o que está acontecendo?

var
r : caractere
i, aux, lote, maior : inteiro
peso : vetor[1..10] de inteiro
soma, media : real
j, tipo : inteiro
x, op : inteiro


inicio
// Seção de Comandos

repita

escreval ("-----==== Controle de Produção ====-----")
escreval ("1 Incluir nova pesagem")
escreval ("2 Limpar últimas 10 leituras")
escreval ("3 Melhores pesagens")
escreval ("4 Total produzido")
escreval ("5 Sair")
leia (op)

se (op = 1) entao

se i<=10 entao
escreval("Entre com o peso do lote")
leia (peso[i])
fimse
escreval ("N° do lote")
lote <- lote + 1
escreval(lote)
fimse

se (op = 2) entao

escreval ("Deseja limpar as dez últimas pesagens")
se i<=10 entao
escreval ("Sim")
fimse

se (op = 3) entao

escreval("Digite 3 para o Top five")
para i de 1 ate 5 passo 1 faca
maior <- (peso[i])
para j e i ate 20 passo 1 faca
se (peso[j]) > maior entao
maior <- (peso[j])
aux <- peso[j]
peso[j] <- peso[i]
peso[i] <- aux
fimse
fimpara
fimpara
para i de 1 ate 10 passo 1 faca
escreva (peso[i])
fimpara

fimse

se (op = 4) entao
escreval ("Total produzido")
para i de n ate 10 passo 1 faca
soma <- soma + (peso[i])
escreval ("Valor total: ", soma)
fimpara
fimse

se (op = 5) entao
escreval ("Sair")
fimse

ate (op = 5)


fimalgoritmo

Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Ajuda, com cadastro e pesagens
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: