VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Ordenação de vetor

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Ordenação de vetor   Qua Out 31, 2007 9:16 am

Como postado no tópico anteriormente.
Eu não sei como ordenar vetores.
E não estou conseguindo fazer o fatorial.

5 - Ler uma matriz A do tipo vetor com 15 elementos. Construir uma matriz B de mesmo tipo e dimensão, sendo que cada elemento da matriz B seja o fatorial do elemento correspondente da matriz A. Apresentar os elementos da matriz B ordenados de forma crescente.

algoritmo "vetor fatorial"
// Função :
// Autor : Gustavo Rodrigues Torre
// Data : 25/10/2007
// Seção de Declarações
var
A,B : vetor[1..15] de real
i: inteiro
inicio
// Seção de Comandos

para i de 1 ate 15 passo 1 faca
escreva("Digite um valor do A", i,":")
leia(A[i])
B[i] <- (A[i]) * i
fimpara
escreval
escreval("Vetor A) Vetor B")

para i de 1 ate 15 passo 1 faca
escreval(" ",A[i]," ",B[i])
fimpara

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
felipeluis
Novato
Novato
avatar

Número de Mensagens : 7
Data de inscrição : 28/10/2007

MensagemAssunto: Re: Ordenação de vetor   Qua Out 31, 2007 3:50 pm

ae eu vi que vc mesmo ja fez esse a fatoração em outro tópico:

fat <- 1
leia (n)
para c de 1 ate n passo 1 faca
fat <- fat*c
fimpara
escreval (fat)

quanto a ordenaçao eu vi que o suporte respondeu essa pergunta pra vc ou outra pessoa

da uma olhada ae =D

http://visualgmaster.livreforum.com/suporte-f4/duvida-ordenacao-t21.htm
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Ordenação de vetor   Qua Out 31, 2007 4:52 pm

Mais eu não estou entendendo onde eu jogo o fatorial.
Poderia me explicar no meu código?
E quanto a ordenação eu não entendi nada.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Ordenação de vetor   Qua Out 31, 2007 6:38 pm

Eu sei que eu fiz
Mais não sei onde colocar isto:
fat <- 1
leia (n)
para c de 1 ate n passo 1 faca
fat <- fat*c
fimpara
escreval (fat)

Alguem me da uma ajuda.
E ordenação eu tb preciso de uma ajuda.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Ordenação de vetor   Qua Out 31, 2007 6:49 pm

Sobre ordenação

Por favor, leia as regras da seção:

Admin escreveu:

Seguem as regras desta seção.

Primeira Regra:

Essa seção é destinada a dúvidas sobre a LÓGICA do algoritmo, sobre dúvidas de como usar uma função, utilize a seção suporte.

Segunda Regra

Não pedir algoritmos prontos, tirem apenas as suas dúvidas, apresentem o algoritmo que vocês querem e o ponto que vocês têm dúvida, ex:

"Faça um algoritmo que sorteie 20 numeros quaisquer de 1 a 200.
e, se for par, armazene em uma variável, se for ímpar, armazene em outra variável"
"Estou com dúvida sobre como sortear os 20 números "
Pedir ou fornecer algoritmos inteiros implica em "ban" por tempo indeterminado.

Terceira Regra

Peça apenas um algoritmo por post. O nome do post deve identificar o algoritmo.

Utilize a seção suporte para tirar sua dúvida de uma função. E leia sua caixa de mensagens.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Ordenação de vetor   Qua Out 31, 2007 6:56 pm

Como diz o enunciado, cada célula da matriz B é o fatorial dessa célula correspondente na matriz A

Por exemplo:

MatrizB[i] <- vet

Obs: você deve cercar quase todo o algoritmo com um 'para' desse tipo :

para i de 1 ate 10 faca

felipeluis escreveu:

ae eu vi que vc mesmo ja fez esse a fatoração em outro tópico:

fat <- 1
leia (n)
para c de 1 ate n passo 1 faca
fat <- fat*c
fimpara
escreval (fat)

quanto a ordenaçao eu vi que o suporte respondeu essa pergunta pra vc ou outra pessoa

da uma olhada ae =D

http://visualgmaster.livreforum.com/suporte-f4/duvida-ordenacao-t21.htm

felipeluis sua linha de pensamento está correta.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Ordenação de vetor   Qua Out 31, 2007 7:06 pm

Apaguei a sua mensagem por engano, por favor re-post.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
Suporte
Administradores
Administradores
avatar

Número de Mensagens : 35
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Ordenação de vetor   Qua Out 31, 2007 7:12 pm

guga, o seguinte código que eu te passei:

fat <- 1
para c de 1 ate i passo 1 faca
leia(i)
fat <- fat * c
fimpara

É algo que você tem que ler e pensar em como foi feito a resolução para depois aplicar com as devidas modificações em seu algoritmo.

Ao invés de fazer a conta de vetor com a variável 'vet', faça com
o elemento da MatrizA

Depois faça o vetor correspondente da MatrizB receber esse valor do cálculo do vetor
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Ordenação de vetor   Qua Out 31, 2007 7:13 pm

Problema resolvido, tópico trancado, mais dúvidas sobre ordenação poste na seção suporte.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
Conteúdo patrocinado




MensagemAssunto: Re: Ordenação de vetor   

Voltar ao Topo Ir em baixo
 
Ordenação de vetor
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Vetor] Retro Stars
» Meu vetor - Desenho
» [Vetor] Desenhando e Vetorizando, [Video] Mickey Mouse
» Visual G - Vetor decrescente
» [EPS]Damask Frames-Stock Vector

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: