VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 duvida algoritmo

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
fastest
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 27
Localização : para
Data de inscrição : 10/05/2012

MensagemAssunto: duvida algoritmo   Qui Maio 10, 2012 5:29 pm

alguem pode me ajudar com esse algoritmo:

Efetuar a leitura de três valores (variáveis A, B e C) e apresentá-los dispostos em ordem crescente
Voltar ao Topo Ir em baixo
Ver perfil do usuário
poet
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 27
Localização : VAI ME SEQUESTRAR??
Data de inscrição : 27/05/2012

MensagemAssunto: Re: duvida algoritmo   Dom Maio 27, 2012 9:18 pm

cara, seria bom se você postasse oque você fez , mais vamos lá .

Eu ussei essa formula:
a = 1
b = 2
c = 3

a =3
b =1
c =2

a =2
b =3
c =1

a =3
b =2
c =1

a =2
b =1
c =3

a =1
b =3
c =2

Então o codigo ficou assim :

Citação :
algoritmo "semnome"
// Função :
// Autor :
// Data : 10/05/2012
// Seção de Declarações
var
a,b,c : inteiro
inicio
// Seção de Comandos
Escreval ("Digite os tres numeros")
Leia (a,b,c)
se (b > a) e (c > b) Entao
Escreval (a,b,c)
fimse
se (c > b) e (a > b) entao
Escreval (b,c,a)
fimse
se (a > c) e (b>a) entao
Escreval (c,a,b)
fimse
se (b > c) e (a>b) entao
Escreval (c,b,a)
fimse
se (a > b) e (c>a) entao
Escreval (b,a,c)
fimse
se (c>a) e (b>c) entao
Escreval (a,c,b)
fimse
fimalgoritmo


abraços
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
duvida algoritmo
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: