VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Duvida matriz

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
algoritimando
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 23
Localização : Sao Paulo
Data de inscrição : 19/05/2012

MensagemAssunto: Duvida matriz   Sab Maio 19, 2012 2:04 pm

Preciso resolver o seguinte algoritimo: Escreva um algoritmo que leia uma matriz de inteiros (5×5) e determine o menor elemento da
linha que contém o maior elemento da matriz. Caso haja repetições, considere a linha com menor
índice. Exiba mensagens significativas para o usuário (por exemplo, “O menor elemento da linha
onde encontra-se o maior elemento da matriz é...”).

Porem até agora só consegui isso:

algoritmo "semnome"

var
m: vetor[1..5, 1..5] de inteiro
i, j: inteiro
maior, posicao: inteiro
inicio

para i de 1 ate 5 faca
para j de 1 ate 5 faca
escreva("Digite o elemento [",i,",",j,"] da matriz m: ")
leia ( m[i,j] )
fimpara
fimpara

para i de 1 ate 5 faca
para j de 1 ate 5 faca
maior <- m[1,1]
se m[i,j] > maior entao
maior <- m[i,j]
fimse
fimpara
fimpara

gostaria de uma ajuda pra continuar! obrigado
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Duvida matriz
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Aula] Array e Matriz em GML
» [DUVIDA] Teria como colocar Boot para punbb
» Duvida com submenu
» Duvida - menu em html
» Duvida sobre postagem dupla

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: