VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Algoritmo do jogo de XADREZ

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
tuelocg
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 37
Localização : campo grande
Data de inscrição : 13/06/2012

MensagemAssunto: Algoritmo do jogo de XADREZ   Qua Jun 13, 2012 8:50 am

olá pessoal tudo bem?

Preciso terminar um trabalho mais ta muito dificil, alguem pode me ajudar?
As peças já estão posicionadas no tabuleiro, agora movimentar as peças é que não tenho a ideia de como!!
Abraço e aguardo respostas!!



algoritmo "xadrez"
var
i,j, px, py, novox, novoy :inteiro //i,j são contadores.
x :vetor[1..8,1..8] de caractere //tabuleiro

procedimento desenhaTabuleiro()
var
inicio
para j de 1 ate 8 faca
escreva(" ",j," ")
fimpara
escreval("")
para j de 1 ate 8 faca
escreva("—————")//"_____")
fimpara
escreval("—")
para i de 1 ate 8 faca
para j de 1 ate 8 faca
escreva("| ", x[i,j]," ")
fimpara
escreval("| ",i)
para j de 1 ate 8 faca
escreva("—————")
fimpara
escreval("—")
fimpara
para j de 1 ate 8 faca
escreva(" ",j," ")
fimpara
escreval("")
fimprocedimento


procedimento ColocaPecasIniciais()
var
inicio
para i de 3 ate 6 faca
para j de 1 ate 8 faca
x[i,j] <- " "
fimpara
fimpara
x[1,1] <- "TP"
x[1,2] <- "CP"
x[1,3] <- "BP"
x[1,4] <- "DP"
x[1,5] <- "RP"
x[1,6] <- "BP"
x[1,7] <- "CP"
x[1,8] <- "TP"
x[8,1] <- "TB"
x[8,2] <- "CB"
x[8,3] <- "BB"
x[8,4] <- "DB"
x[8,5] <- "RB"
x[8,6] <- "BB"
x[8,7] <- "CB"
x[8,8] <- "TB"
para i de 1 ate 8 faca
x[2,i] <- "PP"
x[7,i] <- "PB"
fimpara
fimprocedimento

inicio
ColocaPecasIniciais
//repita
limpatela
desenhaTabuleiro //desenha o tabuleiro completo
//TODO
//ate px <= 0
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Algoritmo do jogo de XADREZ
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Resolvido] Como colocar um jogo de xadrez no fórum?
» como criar um jogo de xadrez?
» Jogo da velha
» Jogo dos parceiros
» Jogo do vo num vo

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: