VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Ajuda com algoritmo para sorteio (mod)

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
ViniciusArryn
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 25
Localização : Rio de Janeiro
Data de inscrição : 10/06/2012

MensagemAssunto: Ajuda com algoritmo para sorteio (mod)   Dom Jun 17, 2012 5:27 pm

Olá, boa tarde! preciso muito de ajuda com um algoritmo para um sorteio. É um trabalho da faculdade que tenho que entregar amanhã, mas sou péssimo em algoritmo e perdi algumas aulas devido ao trabalho =s.

aí está o que se pede: (as partes em vermelho são os tópicos em que estou com dificuldade)


Em uma quermesse, João ficou responsável por realizar o sorteio do prêmio principal. Ele poderia escolher de que forma seriam distribuídos os números e como seria feito o sorteio. João, como um bom programador que é, resolveu criar um programa que fizesse este sorteio e exibisse o vencedor, seguindo os seguintes critérios:
 Assim que um participante chegar à festa deverá escolher um número ao acaso inferior a 100;
 Uma lista de participantes deverá criada e esta deverá respeitar a ordem de chegada de cada um;
 Deve-se efetuar a soma de todos os números escolhidos pelos participantes;
 Deve-se verificar o resto da divisão da soma dos números escolhidos pela quantidade de participantes;
 O vencedor deverá ter chegado à posição igual ao valor deste resto;
 Serão permitidos no máximo 30 participantes.
 O sorteio será realizado assim que este número for atingido, ou quando o realizador do sorteio achar conveniente.

aqui está o que eu fiz até agora:


var


resp : caracter
i, x, soma : inteiro
valores : vetor [1..30] de inteiro
divs : real
inicio

//Para a melhor compreensão do programa, execute-o usando a tecla Shift + F9 em seu teclado.
//desta forma será executado com um temporizador mostrando a linha de código que está sendo executada.

escreval ("Seja bem vindo ao nosso sorteio!")
escreval
soma <- 0
x <- 0
para i de 1 ate 30 faca //estrutura de repetição usada para guardar o cadastro dos participantes.
escreval ("Deseja cadastrar um novo participante? (s/n)")
leia (resp)
Se (resp <> "s") e (resp <> "n") entao // validação para realizar o cadastro.
escreval ("você digitou uma oção inválida! o prgrama será finalizado!")
fimalgoritmo
senao
se (resp = "s") entao // condição para efeutuar o cadastro ou executar o sorteio. serve como saída do laço.
escreval ("Digite um valor que esteja entre 1 e 100: ")
leia (valores[i]) //vetor que armazena os valores escolhidos.
soma <- (soma + valores[i]) //cálculo para a soma de todos os valores escolhidos
x <- x + 1 //variável usada como contadora. guarda a quantidade de participantes.
senao
soma <- (soma + valores[i]) // cálculo para soma dos valores escolhidos em caso de a condição (resp = "s") ter como resultado a falsidade.
se (resp = "n") entao
limpatela
divs <- soma / x
escreval ("A quantidade de participantes é: ", x)

AQUI SE ENCONTRA O MEU PROBLEMA, NÃO SEI COMO FAZER ESSA PARTE:
" Deve-se verificar o resto da divisão da soma dos números escolhidos pela quantidade de participantes;
 O vencedor deverá ter chegado à posição igual ao valor deste resto;"


fimalgoritmo
fimse

fimse
fimse
fimpara

fimalgoritmo

Se puderem me ajudar, ficarei muito grato! desde já agradeço pela atenção! Wink
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Ajuda com algoritmo para sorteio (mod)
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Ajuda como fasso para nao acontecer
» Vossa Ajuda/opinião para minha CRF 250x 2011?
» Lugar onde tem efeitos sonoros
» B - Blocos sorteados
» [TUTORIAL] Mudar rubrica do tema Landscape

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: