VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Ajudaaa!!! Procedimento

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Pepito
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 23
Localização : Porto Alegre
Data de inscrição : 30/06/2012

MensagemAssunto: Ajudaaa!!! Procedimento   Sab Jun 30, 2012 11:28 pm

Meu algo ta louco!
O que fazer:
Elaborar um algoritmo que implemente os procedimentos de Inserção, edição, pesquisa, exclusão e lista. Deve ser utilizada uma estrutura de vetores de no máximo 15 posições para armazenar nome de pessoa. A inserção deverá ser efetuada conforme a necessidade do usuário, ou seja, via menu. Outro aspecto que deverá ser observado é a elaboração da TELA, conforme o exemplo a seguir. Serão avaliados todos os requisitos funcionais. A tela já foi construída somente deverá ser complementada.
repita
escreval (" ------------- T E L A P R I N C I P A L -------------")
escreval
escreval (" [1] - Inserção ")
escreval
escreval (" [2] - Editar ")
escreval
escreval (" [3] - Pesquisar ")
escreval
escreval (" [4] - Excluir ")
escreval
escreval (" [5] - Listar ")
escreval
escreval (" [6] - Finalizar ")
escreval
escreval (" Digite a opção Desejada ")
leia (op)

escolha op

caso 1
nome do procedimento inserção
caso 2
nome do procedimento editar
caso 3
nome do procedimento pesquisar
caso 4
nome do procedimento excluir
caso 5
nome do procedimento lista
fimescolha

ate (op=6)

O que eu fiz:

algoritmo "semnome"
// Função :
// Autor :
// Data : 30/06/2012
// Seção de Declarações
procedimento tres
inicio
teste:=falso
Escreval ("Que nome desejas pesquisar? Digite o número da ficha!")
Leia (i)
enquanto teste=falso faca
Se (i>15) ou (i<1) entao
Escreval("Número inválido!")
Escreval("Tente novamente!")
Leia (i)
senao
Se nom[i]="Vazio" entao
Escreval("Esse nome está vazio!")
Escreval("Tente novamente!")
Leia (i)
senao
teste:=verdadeiro
fimse
fimse
Escreval("O nome de número ",i," é ",nom[i])

fimprocedimento
var
teste:logico
fim:caracter
op,i:inteiro
nom: vetor [1..15] de caracter
inicio
Para i:=1 ate 15 faca
nom[i]:="Vazio"
fimpara
enquanto op<>6 faca
escreval (" ------------- T E L A P R I N C I P A L -------------")
escreval
escreval (" [1] - Inserção ")
escreval
escreval (" [2] - Editar ")
escreval
escreval (" [3] - Pesquisar ")
escreval
escreval (" [4] - Excluir ")
escreval
escreval (" [5] - Listar ")
escreval
escreval (" [6] - Finalizar ")
escreval
escreval (" Digite a opção Desejada ")
leia (op)
limpatela
Escolha (op)
Caso 1
Escreval("Um")
Caso 2
Escreval("Um")
Caso 3
tres
Caso 4
Escreval("Um")
Caso 5
Para i:=1 ate 15 faca
Escreval (nom[i])
fimpara
Caso 6
fim:="sim"
fimescolha
fimenquanto

fimalgoritmo


E TA DANDO ERRO D=
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Ajudaaa!!! Procedimento
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» JAVA NÃO EXECUTA
» [Resolvido]Laudo de procedimento APAC
» [Resolvido]Chamar nome da função armazenado em variável (Call Variavel)
» [Resolvido]Registro de Direitos autorais, Aplicativo criado em Access, é valido? Se faz? se sim qual o Procedimento.
» Repetir Procedimento

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Suporte-
Ir para: