VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 leia quatro numeros e calcule a media somente dos pares

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
henriquecfelix
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 24
Localização : Castanhal, PA
Data de inscrição : 28/09/2012

MensagemAssunto: leia quatro numeros e calcule a media somente dos pares   Sex Set 28, 2012 1:16 am

leia quatro números inteiros e encontre a média aritmética simples entre as que correspondem a números pares.
Lembre-se que não pode haver divisão por zero.
não tô conseguindo entender a lógica... gostaria de um esboço do algoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
henriquecfelix
Novato
Novato


Masculino
Número de Mensagens : 2
Idade : 24
Localização : Castanhal, PA
Data de inscrição : 28/09/2012

MensagemAssunto: Re: leia quatro numeros e calcule a media somente dos pares   Sex Set 28, 2012 12:23 pm

Rosolvido quem tiver com o mesmo problema ta aê a parte chave

a1<-a mod 2
b1<-b mod 2
c1<-c mod 2
d1<-d mod 2
contador<-0
soma<-0
se (a1)=0 entao
contador<-contador+1
soma<-soma+(a)
fimse
se (b1)=0 entao
contador<-contador+1
soma<-soma+(b)
fimse
se (c1)=0 entao
contador<-contador+1
soma<-soma+(c)
fimse
se (d1)=0 entao
contador<-contador+1
soma<-soma+(d)
fimse
se contador<>0 entao
mp<-soma/contador
escreva("Média dos Pares:",mp)
senao
escreva("Não Existe números Pares")
fimse
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
leia quatro numeros e calcule a media somente dos pares
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Go Media Arsenal - Complete Photoshop Brush Sets 1-14
» Expandir o Game Maker com essa LIB de media player
» Como colocar widgets somente no portal
» modificar pontuaçao rank numeros para rank nomes
» [Resolvido] Como fazer somente os tópicos fixos aparecerem no portal?

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: