VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Algoritmo com o comando enquanto

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Lucas Pinheiro
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 21
Localização : São Paulo - SP
Data de inscrição : 06/10/2012

MensagemAssunto: Algoritmo com o comando enquanto    Sab Out 06, 2012 2:21 pm

Fazer um programa que calcule e imprima o fatorial de um número fornecido pelo usuário, usando o comando ENQUANTO. Repetir a execução do programa tantas até o usuário responder nao. O fatorial de um número inteiro positivo é definido como o número multiplicado por ele menos 1, menos 2, etc até o valor 1. Por exemplo, o fatorial de 4 é 4x3x2x1=24.
Exemplo de tela de saída:
Entre com um numero: 5
O fatorial de 5 é 120
Outro número (sim/não) ? não

Alguém me ajuda ajuda a fazer esse algoritmo aqui, por favor
Voltar ao Topo Ir em baixo
Ver perfil do usuário
rafassistec
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 37
Localização : Belo Horizonte
Data de inscrição : 08/09/2014

MensagemAssunto: Re: Algoritmo com o comando enquanto    Seg Set 08, 2014 9:18 pm

algoritmo "Fatorial"
var
numero: inteiro
fatorial: inteiro
inicio
// 1 - Inicializar Variáveis
fatorial <- 1

// 2 - Entrada de Dados
escreva ("Digite o número para calcular a fatorial: ")
leia (numero)

// 3 - Cálculos
enquanto numero > 0 faca
fatorial <- fatorial * numero
numero <- numero - 1
fimenquanto

// 4 - Mensagem de Saída
escreva ("A Fatorial é: ", fatorial)

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Algoritmo com o comando enquanto
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Preciso da ajuda na resolução deste exercicios não resolvidos de Algoritmo! Socorro
» missel comando 3 IMPOSSIBLE (com menu de seleção de dificuldade, nada de bugs e tá mais fácil)
» Substituir comando /me
» Qual é esse comando ?
» Como retirar o comando /me do chatbox

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: