VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Jogo da Velha.

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
GunnerGirl
Novato
Novato


Feminino
Número de Mensagens : 1
Idade : 24
Localização : Curitiba-PR
Data de inscrição : 07/10/2012

MensagemAssunto: Jogo da Velha.   Dom Out 07, 2012 2:27 pm

Boa Tarde Smile
Tenho um trabalho da escola e o exercicio era fazer um Jogo da velha, fiz o seguinte.
Citação :
algoritmo "semnome"
var
vet:vetor [1..3,1..3] de inteiro
i,j,cont:inteiro
x,o,j1,j2:caractere
procedimento imprimir
var
inicio
para i de 1 ate 3 faca
para j de 1 ate 3 faca
se(j=1) entao
escreva(" ",vet[i,j]," || ")
fimse
se(j=2) entao
escreva(vet[i,j]," || ")
fimse
se(j=3) entao
escreval(vet[i,j])
fimse
fimpara
se(i<>3)entao
escreval("================")
fimse
fimpara
escreval
fimprocedimento
inicio
repita
repita
imprimir()
escreval("Jogador 1(x)informe a linha da jogada: ")
leia(i)
ate (i>=1) e (i<=3)
repita
escreval("Jogador 1(x)informe a coluna da jogada: ")
leia(j)
ate (j>=1) e (j<=3)
se(vet[i,j]=0) entao
vet[i,j] <- 1
senao
escreval ("Local já ocupado, jogada invalida: ")
fimse
limpatela
imprimir()
para i de 1 ate 3 faca
para j de 1 ate 3 faca
se (vet[i,1]=1) e (vet[i,2]=1) e (vet[i,3]=1) ou (vet[1,j]=1) e (vet[2,j]=1) e (vet[3,j]=1) ou (vet[1,1]=1) e (vet[2,2]=1) e (vet[3,3]=1) ou (vet[3,1]=1) e (vet[2,2]=1) e (vet[1,3]=1) entao
escreva("Jogador 1(x) voce venceu!")
fimalgoritmo
fimse
fimpara
fimpara
repita
escreval("Jogador 2(o)informe a linha da jogada: ")
leia(i)
ate (i>=1) e (i<=3)
repita
escreval("Jogador 2(o)informe a coluna da jogada: ")
leia(j)
ate (j>=1) e (j<=3)
se(vet[i,j]=0) entao
vet[i,j] <- 2
senao
escreval ("Local já ocupado, jogada invalida: ")
fimse
limpatela
imprimir()
para i de 1 ate 3 faca
para j de 1 ate 3 faca
se (vet[i,1]=2) e (vet[i,2]=2) e (vet[i,3]=2) ou (vet[1,j]=2) e (vet[2,j]=2) e (vet[3,j]=2) ou (vet[1,1]=2) e (vet[2,2]=2) e (vet[3,3]=2) ou (vet[3,1]=2) e (vet[2,2]=2) e (vet[1,3]=2) entao
escreval("Jogador 2(o) voce venceu!")
fimalgoritmo
fimse
fimpara
fimpara
cont<-cont+1
ate cont=9
fimalgoritmo

Mas achei um problema, se o jogador 1 ganha.. ok, se o jogador 2 ganha.. ok também, mas e se der velha? não consegui achar uma solução pra isso. Oque devo usar para saber caso dê velha? Obg Smile
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Jogo da Velha.
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: