VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Matriz Visualg

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
jeferson2121
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 28
Localização : RJ
Data de inscrição : 14/10/2012

MensagemAssunto: Matriz Visualg   Dom Out 14, 2012 12:42 am

Me Ajudem preciso fazer funcionar e não consigo de modo algum !!!
Minha tarefa nesta questão é escrever um algoritmo que processa três vetores, linha1, linha2 e linha3,
correspondentes a cada uma das linhas no pequeno quadrado 3x3 no canto superior esquerdo do Sudoku e
imprime a string 'configuração válida' se este quadrado contém uma instância de cada um dos
dígitos de 1 a 9. Se o quadrado contiver um número inteiro fora desse intervalo ou valores duplicados, o
algoritmo deve imprimir a string 'configuração inválida'.

Ao escrever a sua solução, você pode assumir que as variáveis linha1, linha2 e linha3, já foram
inicializadas com a configuração do quadrado 3x3 no canto superior esquerdo do tabuleiro. Observe, no
entanto, que seu algoritmo deve funcionar para qualquer configuração do pequeno quadrado 3x3 e não
apenas para o exemplo dado.

Exemplo:
início
linha1[1] ← 9 linha1[2] ← 6 linha1[3] ← 3
linha2[1] ← 1 linha2[2] ← 7 linha2[3] ← 8
linha3[1] ← 2 linha3[2] ← 5 linha3[3] ← 6
// seu algoritmo aqui
fim


MEU CODIGO: Tenho que verificar se existe um numero repetido e escrever na tela invalido se por acaso for repetido.

var
matriz :vetor [1..3,1..3] de inteiro
linha, coluna :inteiro
inicio

para linha de 1 ate 3 faca
para coluna de 1 ate 3 faca
leia(matriz[linha,coluna])

fimpara
fimpara
para linha de 1 ate 3 faca
para coluna de 1 ate 3 faca

escreva(matriz[linha,coluna] :4 )

fimpara
escreval("")
fimpara

se (matriz[1]) = (matriz[3,1]) entao
escreval("")
escreva("invalido")
senao
escreva(" válida")

fimse

fimalgoritmo

Ficarei Muito Grato com Qualquer ajuda.
Boa noite Amigos!

Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Matriz Visualg
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Aula] Array e Matriz em GML
» VPN PPTP com 1 matriz e 2 filial ?
» Visual G - Vetor decrescente
» Jogo da velha
» #DGM Aula 03 - Sprites

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: