VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Maior primo

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Maior primo   Qua Out 31, 2007 9:19 am

Faça um algoritmo/programa para ler um número natural N e calcular o maior número primo menor do que o número N.

O que esta dando errado?

algoritmo "maior primo"
// Função :
// Autor : Gustavo Rodrigues Torre
// Data : 11/10/2007
// Seção de Declarações
var
i,x : inteiro
a,c,p,n,maior,iguais : real
inicio
// Seção de Comandos
c <- n
maior <- 900
p <- 0
escreva ("Digite um número ")
leia (n)
para x de 1 ate c passo 1 faca
se (n%x = 0) entao
p <- p + 1
fimse
fimpara

se (p=2) entao
escreval("O numero",n ," é primo.")
senao
escreval("O numero",n ," não é primo.")
fimse

para i de 1 ate 5 passo 1 faca
se (n > maior) entao
maior <- a
fimse

fimpara

escreval("O maior numero primo eh ",maior)

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
cmorgado
Administradores
Administradores


Número de Mensagens : 1
Data de inscrição : 30/10/2007

MensagemAssunto: Re: Maior primo   Sab Nov 03, 2007 10:30 am

Ola.

Em primeiro lugar, declare todas as variáveis como INTEIRO, já que o conceito de números primos pertence ao conjunto dos numeros inteiros.

// Esta parte calcula se um numero é primo...
p <- 0
para x de 2 ate c-1 faca
se (c % x = 0) entao
// Se passou por aqui e pq nao é primo
p <- p + 1
fimse
fimpara

Cada vez que P for zero ao se sair do loop é porque o numero C é primo.
Atribua este valor à variável que controla o meior primo.

Pegue o trecho acima, que é uma modificacao do seu algoritmo, e ponha dentro de um outro loop, onde C varia de 1 ate n.

No fim imprima a variável que controla o maior numero.

Um abraço.

Cláudio Morgado.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Maior primo   Sab Nov 03, 2007 10:58 am

Eu fiz as alterações mais continua dando erro

algoritmo "maior primo"
// Função :
// Autor : Gustavo Rodrigues Torre
// Data : 11/10/2007
// Seção de Declarações
var
i,x : inteiro
a,c,p,n,maior,iguais : inteiro
inicio
// Seção de Comandos
c <- n
maior <- 1
escreva ("Digite um número ")
leia (n)
// Esta parte calcula se um numero é primo...
p <- 0
para x de 2 ate c-1 faca
se (c % x = 0) entao
// Se passou por aqui e pq nao é primo
p <- p + 1
fimse
fimpara

para c de 1 ate n passo 1 faca
se (n > maior) entao
maior <- n
fimse

fimpara

escreval("O maior numero primo eh ",maior)

fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Admin
Administradores
Administradores
avatar

Número de Mensagens : 126
Data de inscrição : 26/10/2007

MensagemAssunto: Re: Maior primo   Sab Nov 03, 2007 11:00 pm

Amigo,
como já devo ter falado um monte de vezes, não é apenas ctrl+c, ctrl+v, não passamos algoritmos prontos aqui, apenas a lógica, então traduza para o seu algoritmo, até os comentarios você colou. Preste atenção:

cmorgado escreveu:
Pegue o trecho acima, que é uma modificacao do seu algoritmo, e ponha dentro de um outro loop, onde C varia de 1 ate n.
guga22 escreveu:
// Seção de Comandos
c <- n
maior <- 1
escreva ("Digite um número ")
leia (n)
// Esta parte calcula se um numero é primo...
p <- 0
para x de 2 ate c-1 faca
se (c % x = 0) entao
// Se passou por aqui e pq nao é primo
p <- p + 1
fimse
fimpara

para c de 1 ate n passo 1 faca
se (n > maior) entao
maior <- n
fimse

fimpara

escreval("O maior numero primo eh ",maior)

fimalgoritmo
Você não colocou o trecho dentro de um outro loop, pense um pouco mais, não so copie e cole.

_________________
Equipe VisualgMaster.
Voltar ao Topo Ir em baixo
Ver perfil do usuário http://visualgmaster.livreforum.com
guga22
Iniciante
Iniciante


Número de Mensagens : 175
Data de inscrição : 27/10/2007

MensagemAssunto: Re: Maior primo   Dom Nov 04, 2007 11:11 am

Ta vou pensar mais um pouco e volto a postar se o algoritmo funcionou mais sem o código ok?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Maior primo   

Voltar ao Topo Ir em baixo
 
Maior primo
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Enduro SPRINT.PT RIO MAIOR 12-5-2013
» Como colocar a assinatura maior
» Deixando a area do avatar maior
» Novo espaço: maior valorização para os tutoriais
» Scroll em imagens com largura maior que a do post

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos :: Algoritmos resolvidos-
Ir para: