VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Erro com algoritimo

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
cappone
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 21
Localização : SP
Data de inscrição : 26/11/2012

MensagemAssunto: Erro com algoritimo   Seg Nov 26, 2012 3:18 pm

algoritmo "Loja De Cd's"

var
quantidade, valor: real
cor: caractere
inicio
escreval("Qual é a cor do CD?")
leia(cor)
se cor=vermelho entao
escreval("CD Vermelho R$ 39,00, Quantos?")
leia(quantidade)
escreval(39*quantidade)
senao cor=azul entao
escreval ("CD Azul R$60,00, Quantos?")
leia(quantidade)
escreval(60*quantidade)
senao cor=verde entao
escreval("CD Verde R$65,00, Quantos?")
leia(quantidade)
escreval(65*quantidade)
senao cor=amarelo entao
escreval("CD Amarelo R$80,00, Quantos?")
leia(quantidade)
escreval(80*quantidade)
fimse

fimalgoritmo

O erro ta na linha que fala da cor vermelha (se cor=vermelho entao), ja tentei de tdos os jeitos...
Voltar ao Topo Ir em baixo
Ver perfil do usuário
wordart
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 20
Localização : Araraquara
Data de inscrição : 26/11/2012

MensagemAssunto: Re: Erro com algoritimo   Seg Nov 26, 2012 5:34 pm

seu problema é com as aspas e o senao!
o algoritmo é esse:
algoritmo "Loja De Cd's"

var
quantidade, valor: real
cor: caractere
inicio
escreval("Qual é a cor do CD?")
leia(cor)
se cor="vermelho" entao
escreval("CD Vermelho R$ 39,00, Quantos?")
leia(quantidade)
escreval(39*quantidade," reais")
senao
se cor="azul" entao
escreval ("CD Azul R$60,00, Quantos?")
leia(quantidade)
escreval(60*quantidade," reais")
senao
se cor="verde" entao
escreval("CD Verde R$65,00, Quantos?")
leia(quantidade)
escreval(65*quantidade," reais")
senao
se cor="amarelo" entao
escreval("CD Amarelo R$80,00, Quantos?")
leia(quantidade)
escreval(80*quantidade," reais")
fimse
fimse
fimse
fimse
fimalgoritmo
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Erro com algoritimo
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» erro com projeção esquisito.....
» Erro no post
» Erro na descrição
» Erro de código
» Erro no redirecionamento

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Suporte-
Ir para: