VisualgMaster

Bem vindo ao fórum visualgmaster, tudo relacionado ao visualg, tire suas dúvidas, resolva seus algoritmos.
 
InícioInício  PortalPortal  FAQFAQ  BuscarBuscar  Registrar-seRegistrar-se  MembrosMembros  GruposGrupos  Conectar-se  

Compartilhe | 
 

 Ler Base e Expoente no VISUAL G

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
gabriels2
Novato
Novato


Masculino
Número de Mensagens : 1
Idade : 22
Localização : Fortaleza
Data de inscrição : 12/05/2013

MensagemAssunto: Ler Base e Expoente no VISUAL G   Dom Maio 12, 2013 7:44 pm

Galera, quero fazer um exercício que pede para a pessoa escolher qualquer base e qualquer expoente, e realizar a potenciação. Dai só considerando a base e o expoente como INTEIRO E POSITIVO.
Preciso que alguém me ajuda a descobrir o erro please!

"algoritmo "Ler Potencia e Expoente"
var
C: caractere
Y: inteiro
X: inteiro
R: inteiro
CONT: inteiro

inicio
escreva ("Base que deseja usar: ", X)
leia (X)
escreva ("Elevado ao número: ", Y)
leia (Y)
R <- X
Se (Y = 0) entao
R <- 1
senao
Se X = 0 entao
R <- 0
senao
para CONT de 1 ate Y passo -1 faca
R <- R * Y
fimpara
fimse
fimse
escreva ("O resultado é: ", R)
fimalgoritmo"
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Ler Base e Expoente no VISUAL G
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Acesso de leitura às Base-de-dados
» Mudar o visual da caixa de escrita do tópico
» Codigo php visual main status
» Como aceder ao css base
» Como mudar o visual do chatbox ???

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
VisualgMaster :: VisualgMaster :: Pedidos de algoritmos-
Ir para: